lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 22 Mar 2019 12:15:06 +0530
From:   Vinod Koul <vkoul@...nel.org>
To:     Aaro Koskinen <aaro.koskinen@....fi>
Cc:     "David S. Miller" <davem@...emloft.net>, netdev@...r.kernel.org,
        linux-mips@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [BISECTED, REGRESSION] Broken networking on MIPS/OCTEON
 EdgeRouter Lite

On 22-03-19, 02:21, Aaro Koskinen wrote:
> Hi,
> 
> When booting v5.1-rc1 on EdgeRouter Lite (MIPS/OCTEON), with at803x phy
> driver enabled, networking no longer works - I even need to go physically
> power cycle the board before getting networking to work again (otherwise
> bootloader cannot tftp an older working image).
> 
> Bisected to:
> 
> 	commit 6d4cd041f0af5b4c8fc742b4a68eac22e420e28c
> 	Author: Vinod Koul <vkoul@...nel.org>
> 	Date:   Thu Feb 21 15:53:15 2019 +0530
> 
> 	    net: phy: at803x: disable delay only for RGMII mode

Hello,

So with cd28d1d6e52e ("net: phy: at803x: Disable phy delay for RGMII
mode") it works for you but not 6d4cd041f0af ("net: phy: at803x: disable
delay only for RGMII mode"). That is bit more weird case :)

So does the ethernet expect RGMII mode or RGMII_ID mode here, looks like
disable delay is expected as well?

Can you point me to the DT node as well..

> Booting v5.1-rc1 with this commit reverted makes networking to work
> fine again.

-- 
~Vinod

Powered by blists - more mailing lists