lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 22 Mar 2019 21:35:41 +0000
From:   "Ghannam, Yazen" <Yazen.Ghannam@....com>
To:     Borislav Petkov <bp@...en8.de>
CC:     "linux-edac@...r.kernel.org" <linux-edac@...r.kernel.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
        "tony.luck@...el.com" <tony.luck@...el.com>,
        "x86@...nel.org" <x86@...nel.org>,
        "rafal@...ecki.pl" <rafal@...ecki.pl>,
        "clemej@...il.com" <clemej@...il.com>
Subject: RE: [PATCH v3 2/3] x86/MCE/AMD: Don't report L1 BTB MCA errors on
 some Family 17h models

> -----Original Message-----
> From: linux-edac-owner@...r.kernel.org <linux-edac-owner@...r.kernel.org> On Behalf Of Borislav Petkov
> Sent: Friday, March 22, 2019 3:55 PM
> To: Ghannam, Yazen <Yazen.Ghannam@....com>
> Cc: linux-edac@...r.kernel.org; linux-kernel@...r.kernel.org; tony.luck@...el.com; x86@...nel.org; rafal@...ecki.pl;
> clemej@...il.com
> Subject: Re: [PATCH v3 2/3] x86/MCE/AMD: Don't report L1 BTB MCA errors on some Family 17h models
> 
> On Fri, Mar 22, 2019 at 08:37:08PM +0000, Ghannam, Yazen wrote:
> > Sorry, I forgot to mention this. I went with "filter_mce_amd" because
> > amd_filter_mce() is already defined in edac/mce_amd.c and there was
> > a conflict when building. Is there another way to avoid these naming
> > conflicts?
> 
> Yuck, we're clearly filtering too much. :)
> 
> So let's rename that amd_filter_mce() to something else since it is
> static and only used in that file. Maybe something like
> 
>         if (ignore_mce(m))
>                 return NOTIFY_STOP;
> 
> so that we can keep the "filter" notion all reserved to the core MCA
> code and there's no confusion.
> 
> And then amd_filter_mce() is free to be used in the core code.
> 

Okay, will do.

Should this be a pre-patch, or just include it here?

Thanks,
Yazen

Powered by blists - more mailing lists