[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20190325145428.b826c281daa7f5cd1f110efe@linux-foundation.org>
Date: Mon, 25 Mar 2019 14:54:28 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Yury Norov <yury.norov@...il.com>
Cc: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Rasmus Villemoes <linux@...musvillemoes.dk>,
Arnd Bergmann <arnd@...db.de>,
Kees Cook <keescook@...omium.org>,
Matthew Wilcox <willy@...radead.org>,
Tetsuo Handa <penguin-kernel@...ove.SAKURA.ne.jp>,
Yury Norov <ynorov@...vell.com>, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 2/6] bitmap_parselist: move non-parser logic to helpers
On Tue, 26 Mar 2019 00:07:44 +0300 Yury Norov <yury.norov@...il.com> wrote:
> --- a/lib/bitmap.c
> +++ b/lib/bitmap.c
> @@ -477,6 +477,42 @@ int bitmap_print_to_pagebuf(bool list, char *buf, const unsigned long *maskp,
> }
> EXPORT_SYMBOL(bitmap_print_to_pagebuf);
>
> +/*
> + * Region 9-38:4/10 describes the following bitmap structure:
> + * 0 9 12 18 38
> + * .........****......****......****......
> + * ^ ^ ^ ^
> + * start off grlen end
> + */
> +struct region {
> + unsigned int start;
> + unsigned int off;
> + unsigned int grlen;
> + unsigned int end;
> +};
grlen means... group_len, I think?
Perhaps it should be called group_len ;)
Powered by blists - more mailing lists