[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190326102843.GA10264@icarus>
Date: Tue, 26 Mar 2019 19:28:43 +0900
From: William Breathitt Gray <vilhelm.gray@...il.com>
To: Andy Shevchenko <andy.shevchenko@...il.com>,
Lukas Wunner <lukas@...ner.de>
Cc: linus.walleij@...aro.org, bgolaszewski@...libre.com,
akpm@...ux-foundation.org, linux-gpio@...r.kernel.org,
linux-arch@...r.kernel.org, linux-kernel@...r.kernel.org,
linux@...musvillemoes.dk, yamada.masahiro@...ionext.com,
linux-arm-kernel@...ts.infradead.org, linux-pm@...r.kernel.org,
geert@...ux-m68k.org, preid@...ctromag.com.au,
Arnd Bergmann <arnd@...db.de>
Subject: Re: [PATCH v12 01/11] bitops: Introduce the for_each_set_clump8 macro
On Tue, Mar 26, 2019 at 12:19:33PM +0200, Andy Shevchenko wrote:
> On Tue, Mar 26, 2019 at 07:08:18PM +0900, William Breathitt Gray wrote:
> > On Tue, Mar 26, 2019 at 10:43:45AM +0100, Lukas Wunner wrote:
> > > On Tue, Mar 26, 2019 at 12:14:22PM +0900, William Breathitt Gray wrote:
>
> > > Why is it so complicated, does it allow passing in a start value
> > > that's not a multiple of 8? Do you really need that? I imagine
> > > a simplification is possible if that assumption can be made (and
> > > is spelled out in the kerneldoc).
> >
> > That's a good point. Originally, I had envisioned the possibility of
> > calling bitmap_get_value8/bitmap_set_value8 at odd start offsets; this
> > would open up the possibility of a clump landing as a split between 2
> > words, thus requiring this complicated case handling code. However, I'm
> > not sure how often users would need this case; none of the drivers right
> > now require clumps at odd offsets.
> >
> > Andy, would you have any objection to restricting the start offset
> > values for bitmap_get_value8/bitmap_set_value8 to multiples of 8? That
> > would prevent the split word case, and thus allow the implementation for
> > those functions to be a lot simpler.
>
> No, I have no objection.
>
> --
> With Best Regards,
> Andy Shevchenko
In this case, bitmap_get_value8 could be simplified to something like
this:
index = BIT_WORD(start);
offset = start % BITS_PER_LONG;
return (bitmap[index] >> offset) & 0xFF;
Or if you prefer a single line:
(bitmap[BIT_WORD(start)] >> (start % BITS_PER_LONG)) & 0xFF;
Would it be better to define bitmap_get_value8 as a macro then?
William Breathitt Gray
Powered by blists - more mailing lists