[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190326133248.2nrm5javjw4vd2yq@paasikivi.fi.intel.com>
Date: Tue, 26 Mar 2019 15:32:48 +0200
From: Sakari Ailus <sakari.ailus@...ux.intel.com>
To: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
Cc: Petr Mladek <pmladek@...e.com>, linux-kernel@...r.kernel.org,
rafael@...nel.org, linux-acpi@...r.kernel.org,
devicetree@...r.kernel.org, Rob Herring <robh@...nel.org>
Subject: Re: [PATCH v2 3/6] device property: Add a function to obtain a
node's prefix
Hi Andy,
On Tue, Mar 26, 2019 at 03:16:26PM +0200, Andy Shevchenko wrote:
> On Tue, Mar 26, 2019 at 02:41:03PM +0200, Sakari Ailus wrote:
> > The prefix is used for printing purpose before a node, and it also works
> > as a separator between two nodes.
> >
>
> One nit below.
>
> > +static const char *
> > +acpi_fwnode_get_name_prefix(const struct fwnode_handle *fwnode)
> > +{
> > + struct fwnode_handle *parent;
> > +
>
> > + parent = fwnode_get_parent(fwnode);
> > + /* Root node. */
>
> I guess a comment could be easier to read if it goes before parent assignment
> line.
Only if the comments are changed accordingly. What we're doing here is
trying to figure out whether this is the root node. I can do that for v3.
>
> > + if (!parent)
> > + return "";
> > +
> > + parent = fwnode_get_next_parent(parent);
> > + /* Second node from the root; no prefix here either. */
>
> Ditto.
>
> > + if (!parent)
> > + return "";
> > +
> > + fwnode_handle_put(parent);
> > +
> > + /* ACPI device or data node. */
> > + return ".";
> > +}
--
Regards,
Sakari Ailus
sakari.ailus@...ux.intel.com
Powered by blists - more mailing lists