[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <21036602-c062-8f32-ee81-7eb80f348982@linaro.org>
Date: Mon, 1 Apr 2019 09:25:42 -0500
From: Alex Elder <elder@...aro.org>
To: Will Cunningham <wjcunningham7@...il.com>, johan@...nel.org
Cc: elder@...nel.org, gregkh@...uxfoundation.org,
devel@...verdev.osuosl.org, linux-kernel@...r.kernel.org,
joe@...ches.com
Subject: Re: [PATCH v2] Staging: greybus: usb: Fixed a coding style error
On 4/1/19 9:22 AM, Will Cunningham wrote:
> Line was >80 characters.
This looks fine, but "tmp" is not a meaningful name.
That argument to gb_connection_create() is a cport id,
so "cport_id" would be a much better name for the variable.
It seems picky, but details like this make the code much
more understandable.
-Alex
> Signed-off-by: Will Cunningham <wjcunningham7@...il.com>
> ---
> Changes in v2:
> - Created a tmp variable to shorten line length.
> ---
> drivers/staging/greybus/usb.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/staging/greybus/usb.c b/drivers/staging/greybus/usb.c
> index 1c246c73a085..c09793b48850 100644
> --- a/drivers/staging/greybus/usb.c
> +++ b/drivers/staging/greybus/usb.c
> @@ -163,14 +163,14 @@ static int gb_usb_probe(struct gbphy_device *gbphy_dev,
> struct gb_usb_device *gb_usb_dev;
> struct usb_hcd *hcd;
> int retval;
> + u16 tmp;
>
> hcd = usb_create_hcd(&usb_gb_hc_driver, dev, dev_name(dev));
> if (!hcd)
> return -ENOMEM;
>
> - connection = gb_connection_create(gbphy_dev->bundle,
> - le16_to_cpu(gbphy_dev->cport_desc->id),
> - NULL);
> + tmp = le16_to_cpu(gbphy_dev->cport_desc->id);
> + connection = gb_connection_create(gbphy_dev->bundle, tmp, NULL);
> if (IS_ERR(connection)) {
> retval = PTR_ERR(connection);
> goto exit_usb_put;
>
Powered by blists - more mailing lists