[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <20190403185310.8437-2-matwey@sai.msu.ru>
Date: Wed, 3 Apr 2019 21:53:05 +0300
From: "Matwey V. Kornilov" <matwey@....msu.ru>
To: b-liu@...com, gregkh@...uxfoundation.org
Cc: matwey.kornilov@...il.com,
"Matwey V. Kornilov" <matwey@....msu.ru>,
linux-kernel@...r.kernel.org, linux-usb@...r.kernel.org
Subject: [PATCH 1/6] usb: musb: Use USB_DIR_IN when calling musb_advance_schedule()
Use USB_DIR_IN instead of 1 when calling musb_advance_schedule().
This is consistent with the rest of musb_host.c code and impoves
the readability.
Signed-off-by: Matwey V. Kornilov <matwey@....msu.ru>
---
drivers/usb/musb/musb_host.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/usb/musb/musb_host.c b/drivers/usb/musb/musb_host.c
index eb308ec35c66..3ffea6a5e022 100644
--- a/drivers/usb/musb/musb_host.c
+++ b/drivers/usb/musb/musb_host.c
@@ -1195,7 +1195,7 @@ irqreturn_t musb_h_ep0_irq(struct musb *musb)
/* call completion handler if done */
if (complete)
- musb_advance_schedule(musb, urb, hw_ep, 1);
+ musb_advance_schedule(musb, urb, hw_ep, USB_DIR_IN);
done:
return retval;
}
--
2.16.4
Powered by blists - more mailing lists