[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190412001941.GV15524@magnolia>
Date: Thu, 11 Apr 2019 17:19:41 -0700
From: "Darrick J. Wong" <darrick.wong@...cle.com>
To: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Cc: linux-xfs@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] xfs: use struct_size() helper
[fixing linux-xfs cc]
On Thu, Apr 11, 2019 at 06:37:58PM -0500, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes, in particular in the
> context in which this code is being used.
>
> So, replace code of the following form:
>
> sizeof(*alist) + context->count * sizeof(alist->al_offset[0]
>
> with:
>
> struct_size(alist, al_offset, context->count)
>
> and remove unnecessary variable arraytop.
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>
Has this been run through xfstests?
--D
> fs/xfs/xfs_attr_list.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/fs/xfs/xfs_attr_list.c b/fs/xfs/xfs_attr_list.c
> index 3d213a7394c5..05e03348553e 100644
> --- a/fs/xfs/xfs_attr_list.c
> +++ b/fs/xfs/xfs_attr_list.c
> @@ -553,7 +553,6 @@ xfs_attr_put_listent(
> {
> struct attrlist *alist = (struct attrlist *)context->alist;
> attrlist_ent_t *aep;
> - int arraytop;
>
> ASSERT(!context->seen_enough);
> ASSERT(!(context->flags & ATTR_KERNOVAL));
> @@ -572,10 +571,8 @@ xfs_attr_put_listent(
> ((flags & XFS_ATTR_ROOT) == 0))
> return;
>
> - arraytop = sizeof(*alist) +
> - context->count * sizeof(alist->al_offset[0]);
> context->firstu -= ATTR_ENTSIZE(namelen);
> - if (context->firstu < arraytop) {
> + if (context->firstu < struct_size(alist, al_offset, context->count)) {
> trace_xfs_attr_list_full(context);
> alist->al_more = 1;
> context->seen_enough = 1;
> --
> 2.21.0
>
Powered by blists - more mailing lists