lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Sat, 13 Apr 2019 18:05:04 -0700
From:   Andrey Smirnov <andrew.smirnov@...il.com>
To:     Jonathan Cameron <jic23@...nel.org>
Cc:     linux-iio@...r.kernel.org, Hartmut Knaack <knaack.h@....de>,
        Lars-Peter Clausen <lars@...afoo.de>,
        Peter Meerwald-Stadler <pmeerw@...erw.net>,
        Chris Healy <cphealy@...il.com>,
        linux-kernel <linux-kernel@...r.kernel.org>,
        Haibo Chen <haibo.chen@...escale.com>
Subject: Re: [PATCH 5/6] iio: imx7d_adc: Use imx7d_adc_resume() in imx7d_adc_probe()

On Sun, Apr 7, 2019 at 4:15 AM Jonathan Cameron <jic23@...nel.org> wrote:
>
> On Wed,  3 Apr 2019 00:03:24 -0700
> Andrey Smirnov <andrew.smirnov@...il.com> wrote:
>
> > Initialization sequence performed in imx7d_adc_resume() is exactley
> > the same as what's being done in imx7d_adc_probe(). Make use of the
> > former in the latter to avoid code duplication.
> >
> > Signed-off-by: Andrey Smirnov <andrew.smirnov@...il.com>
> > Cc: Jonathan Cameron <jic23@...nel.org>
> > Cc: Hartmut Knaack <knaack.h@....de>
> > Cc: Lars-Peter Clausen <lars@...afoo.de>
> > Cc: Peter Meerwald-Stadler <pmeerw@...erw.net>
> > Cc: Chris Healy <cphealy@...il.com>
> > Cc: linux-iio@...r.kernel.org
> > Cc: linux-kernel@...r.kernel.org
> I'm not to going to apply this now, due to the ordering issue with the earlier
> and later patches.  However, it is fine in of itself.
>
> I do wonder if we want to rename resume to something else to reflect
> it's new usage?  imx7d_adc_enable perhaps?
> Similar question for suspend in the next patch.

Sure, will rename in v2.

Thanks,
Andrey Smirnov

Powered by blists - more mailing lists