lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 15 Apr 2019 06:56:13 +0000
From:   Peter Rosin <peda@...ntia.se>
To:     Ray Jui <ray.jui@...adcom.com>, Wolfram Sang <wsa@...-dreams.de>
CC:     "linux-i2c@...r.kernel.org" <linux-i2c@...r.kernel.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
        "bcm-kernel-feedback-list@...adcom.com" 
        <bcm-kernel-feedback-list@...adcom.com>,
        Rayagonda Kokatanur <rayagonda.kokatanur@...adcom.com>
Subject: Re: [PATCH] i2c: iproc: Change driver to use 'BIT' macro

On 2019-04-13 00:59, Peter Rosin wrote:
> On 2019-04-03 23:05, Ray Jui wrote:
>> Change the iProc I2C driver to use the 'BIT' macro from all '1 << XXX'
>> bit operations to get rid of compiler warning and improve readability of
>> the code
> 
> All? I see lots more '1 << XXX_SHIFT' matches. I might be behind though?

I verified that, and yes indeed, I was behind. That said, see below...

> Anyway, if you are cleaning up, I'm just flagging that BIT(XXX_SHIFT) looks
> a bit clunky to me. You might consider renaming all those single-bit
> XXX_SHIFT macros to simple be
> 
> #define XXX BIT(<xxx>)
> 
> instead of
> 
> #define XXX_SHIFT <xxx>
> 
> but that triggers more churn, so is obviously more error prone. You might
> not dare it?
> 
> Cheers,
> Peter
> 
>> Signed-off-by: Ray Jui <ray.jui@...adcom.com>
>> ---
>>  drivers/i2c/busses/i2c-bcm-iproc.c | 6 +++---
>>  1 file changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/drivers/i2c/busses/i2c-bcm-iproc.c b/drivers/i2c/busses/i2c-bcm-iproc.c
>> index 562942d0c05c..a845b8decac8 100644
>> --- a/drivers/i2c/busses/i2c-bcm-iproc.c
>> +++ b/drivers/i2c/busses/i2c-bcm-iproc.c
>> @@ -717,7 +717,7 @@ static int bcm_iproc_i2c_xfer_single_msg(struct bcm_iproc_i2c_dev *iproc_i2c,
>>  
>>  			/* mark the last byte */
>>  			if (i == msg->len - 1)
>> -				val |= 1 << M_TX_WR_STATUS_SHIFT;
>> +				val |= BIT(M_TX_WR_STATUS_SHIFT);
>>  
>>  			iproc_i2c_wr_reg(iproc_i2c, M_TX_OFFSET, val);
>>  		}
>> @@ -844,7 +844,7 @@ static int bcm_iproc_i2c_cfg_speed(struct bcm_iproc_i2c_dev *iproc_i2c)
>>  
>>  	iproc_i2c->bus_speed = bus_speed;
>>  	val = iproc_i2c_rd_reg(iproc_i2c, TIM_CFG_OFFSET);
>> -	val &= ~(1 << TIM_CFG_MODE_400_SHIFT);
>> +	val &= ~BIT(TIM_CFG_MODE_400_SHIFT);
>>  	val |= (bus_speed == 400000) << TIM_CFG_MODE_400_SHIFT;

These two statements now no longer "match". One uses BIT and the other open
codes the shift. I think that's bad. Losing the _SHIFT suffix and including
BIT in the macro expansion, as suggested above, yields:

	val &= ~TIM_CFG_MODE_400;
	if (bus_speed == 400000)
		val |= TIM_CFG_MODE_400;

which is perhaps one more line, but also more readable IMO.

But all this is of course in deep nit-pick-territory...

Cheers,
Peter

>>  	iproc_i2c_wr_reg(iproc_i2c, TIM_CFG_OFFSET, val);
>>  
>> @@ -995,7 +995,7 @@ static int bcm_iproc_i2c_resume(struct device *dev)
>>  
>>  	/* configure to the desired bus speed */
>>  	val = iproc_i2c_rd_reg(iproc_i2c, TIM_CFG_OFFSET);
>> -	val &= ~(1 << TIM_CFG_MODE_400_SHIFT);
>> +	val &= ~BIT(TIM_CFG_MODE_400_SHIFT);
>>  	val |= (iproc_i2c->bus_speed == 400000) << TIM_CFG_MODE_400_SHIFT;
>>  	iproc_i2c_wr_reg(iproc_i2c, TIM_CFG_OFFSET, val);
>>  
>>
> 

Powered by blists - more mailing lists