[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAPcyv4jPOF_+R6U17J_+88+X8LC-LSPCugA6gbKxuphuuFB2gg@mail.gmail.com>
Date: Thu, 18 Apr 2019 11:14:59 -0700
From: Dan Williams <dan.j.williams@...el.com>
To: Christoph Hellwig <hch@...radead.org>
Cc: Jeff Moyer <jmoyer@...hat.com>, Jan Kara <jack@...e.cz>,
Pankaj Gupta <pagupta@...hat.com>,
linux-nvdimm <linux-nvdimm@...ts.01.org>,
Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
virtualization@...ts.linux-foundation.org,
KVM list <kvm@...r.kernel.org>,
linux-fsdevel <linux-fsdevel@...r.kernel.org>,
Linux ACPI <linux-acpi@...r.kernel.org>,
Qemu Developers <qemu-devel@...gnu.org>,
linux-ext4 <linux-ext4@...r.kernel.org>,
linux-xfs <linux-xfs@...r.kernel.org>,
Ross Zwisler <zwisler@...nel.org>,
Vishal L Verma <vishal.l.verma@...el.com>,
Dave Jiang <dave.jiang@...el.com>,
"Michael S. Tsirkin" <mst@...hat.com>,
Jason Wang <jasowang@...hat.com>,
Matthew Wilcox <willy@...radead.org>,
"Rafael J. Wysocki" <rjw@...ysocki.net>,
Len Brown <lenb@...nel.org>, "Theodore Ts'o" <tytso@....edu>,
Andreas Dilger <adilger.kernel@...ger.ca>,
"Darrick J. Wong" <darrick.wong@...cle.com>,
lcapitulino@...hat.com, Kevin Wolf <kwolf@...hat.com>,
Igor Mammedov <imammedo@...hat.com>,
Nitesh Narayan Lal <nilal@...hat.com>,
Rik van Riel <riel@...riel.com>,
Stefan Hajnoczi <stefanha@...hat.com>,
Andrea Arcangeli <aarcange@...hat.com>,
David Hildenbrand <david@...hat.com>,
david <david@...morbit.com>, cohuck@...hat.com,
Xiao Guangrong <xiaoguangrong.eric@...il.com>,
Paolo Bonzini <pbonzini@...hat.com>, kilobyte@...band.pl,
yuval shaia <yuval.shaia@...cle.com>
Subject: Re: [PATCH v5 1/6] libnvdimm: nd_region flush callback support
On Thu, Apr 18, 2019 at 9:18 AM Christoph Hellwig <hch@...radead.org> wrote:
>
> On Thu, Apr 18, 2019 at 09:05:05AM -0700, Dan Williams wrote:
> > > > I'd either add a comment about avoiding retpoline overhead here or just
> > > > make ->flush == NULL mean generic_nvdimm_flush(). Just so that people don't
> > > > get confused by the code.
> > >
> > > Isn't this premature optimization? I really don't like adding things
> > > like this without some numbers to show it's worth it.
> >
> > I don't think it's premature given this optimization technique is
> > already being deployed elsewhere, see:
> >
> > https://lwn.net/Articles/774347/
>
> For one this one was backed by numbers, and second after feedback
> from Linux we switched to the NULL pointer check instead.
Ok I should have noticed the switch to NULL pointer check. However,
the question still stands do we want everyone to run numbers to
justify this optimization, or make it a new common kernel coding
practice to do:
if (!object->op)
generic_op(object);
else
object->op(object);
...in hot paths? I agree with not doing premature optimization in
principle, but this hack is minimally intrusive from a readability
perspective similar to likely()/unlikely() usage which also don't come
with numbers on a per patch basis.
Powered by blists - more mailing lists