[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <472ef0468852806f6afa8aa6e7713de2@codeaurora.org>
Date: Tue, 30 Apr 2019 13:14:40 +0530
From: Balakrishna Godavarthi <bgodavar@...eaurora.org>
To: Matthias Kaehlcke <mka@...omium.org>
Cc: Marcel Holtmann <marcel@...tmann.org>,
Johan Hedberg <johan.hedberg@...il.com>,
linux-bluetooth@...r.kernel.org, linux-kernel@...r.kernel.org,
Harish Bandi <c-hbandi@...eaurora.org>,
Rocky Liao <rjliao@...eaurora.org>
Subject: Re: [PATCH v3 1/2] Bluetooth: hci_qca: Rename STATE_<flags> to
QCA_<flags>
Hi Mathhias,
On 2019-04-30 04:51, Matthias Kaehlcke wrote:
> Rename STATE_IN_BAND_SLEEP_ENABLED to QCA_IBS_ENABLED. The constant
> represents a flag (multiple flags can be set at once), not a unique
> state of the controller or driver.
>
> Also make the flag an enum value instead of a pre-processor constant
> (more flags will be added to the enum group by another patch).
>
> Signed-off-by: Matthias Kaehlcke <mka@...omium.org>
> ---
> Changes in v3:
> - rename STATE_IN_BAND_SLEEP_ENABLED to QCA_IBS_ENABLED
>
> Changes in v2:
> - don't use BIT()
> - change to enum type
> - updated commit message
> ---
> drivers/bluetooth/hci_qca.c | 15 ++++++++-------
> 1 file changed, 8 insertions(+), 7 deletions(-)
>
> diff --git a/drivers/bluetooth/hci_qca.c b/drivers/bluetooth/hci_qca.c
> index c53ee8d8ca15..57322c42bb2d 100644
> --- a/drivers/bluetooth/hci_qca.c
> +++ b/drivers/bluetooth/hci_qca.c
> @@ -54,9 +54,6 @@
> #define HCI_IBS_WAKE_ACK 0xFC
> #define HCI_MAX_IBS_SIZE 10
>
> -/* Controller states */
> -#define STATE_IN_BAND_SLEEP_ENABLED 1
> -
> #define IBS_WAKE_RETRANS_TIMEOUT_MS 100
> #define IBS_TX_IDLE_TIMEOUT_MS 2000
> #define CMD_TRANS_TIMEOUT_MS 100
> @@ -67,6 +64,10 @@
> /* Controller debug log header */
> #define QCA_DEBUG_HANDLE 0x2EDC
>
> +enum qca_flags {
> + QCA_IBS_ENABLED,
> +};
> +
> /* HCI_IBS transmit side sleep protocol states */
> enum tx_ibs_states {
> HCI_IBS_TX_ASLEEP,
> @@ -792,7 +793,7 @@ static int qca_enqueue(struct hci_uart *hu, struct
> sk_buff *skb)
> /* Don't go to sleep in middle of patch download or
> * Out-Of-Band(GPIOs control) sleep is selected.
> */
> - if (!test_bit(STATE_IN_BAND_SLEEP_ENABLED, &qca->flags)) {
> + if (!test_bit(QCA_IBS_ENABLED, &qca->flags)) {
> skb_queue_tail(&qca->txq, skb);
> spin_unlock_irqrestore(&qca->hci_ibs_lock, flags);
> return 0;
> @@ -1202,7 +1203,7 @@ static int qca_setup(struct hci_uart *hu)
> return ret;
>
> /* Patch downloading has to be done without IBS mode */
> - clear_bit(STATE_IN_BAND_SLEEP_ENABLED, &qca->flags);
> + clear_bit(QCA_IBS_ENABLED, &qca->flags);
>
> if (qca_is_wcn399x(soc_type)) {
> bt_dev_info(hdev, "setting up wcn3990");
> @@ -1246,7 +1247,7 @@ static int qca_setup(struct hci_uart *hu)
> /* Setup patch / NVM configurations */
> ret = qca_uart_setup(hdev, qca_baudrate, soc_type, soc_ver);
> if (!ret) {
> - set_bit(STATE_IN_BAND_SLEEP_ENABLED, &qca->flags);
> + set_bit(QCA_IBS_ENABLED, &qca->flags);
> qca_debugfs_init(hdev);
> } else if (ret == -ENOENT) {
> /* No patch/nvm-config found, run with original fw/config */
> @@ -1315,7 +1316,7 @@ static void qca_power_shutdown(struct hci_uart
> *hu)
> * data in skb's.
> */
> spin_lock_irqsave(&qca->hci_ibs_lock, flags);
> - clear_bit(STATE_IN_BAND_SLEEP_ENABLED, &qca->flags);
> + clear_bit(QCA_IBS_ENABLED, &qca->flags);
> qca_flush(hu);
> spin_unlock_irqrestore(&qca->hci_ibs_lock, flags);
Change looks fine to me.
Reviewed-by: Balakrishna Godavarthi <bgodavar@...eaurora.org>
--
Regards
Balakrishna.
Powered by blists - more mailing lists