lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 6 May 2019 17:04:53 -0700
From:   "Paul E. McKenney" <paulmck@...ux.ibm.com>
To:     "Joel Fernandes (Google)" <joel@...lfernandes.org>
Cc:     linux-kernel@...r.kernel.org, rcu@...r.kernel.org,
        Josh Triplett <josh@...htriplett.org>,
        Steven Rostedt <rostedt@...dmis.org>,
        Mathieu Desnoyers <mathieu.desnoyers@...icios.com>,
        Lai Jiangshan <jiangshanlai@...il.com>,
        Jonathan Corbet <corbet@....net>, linux-doc@...r.kernel.org
Subject: Re: [PATCH] doc/rcu: Correct field_count field naming in examples

On Sat, May 04, 2019 at 10:03:10PM -0400, Joel Fernandes (Google) wrote:
> I believe this field should be called field_count instead of file_count.
> Correct the doc with the same.
> 
> Signed-off-by: Joel Fernandes (Google) <joel@...lfernandes.org>

But if we are going to update this, why not update it with the current
audit_filter_task(), audit_del_rule(), and audit_add_rule() code?

Hmmm...  One reason is that some of them have changed beyond recognition.

And this example code predates v2.6.12.  ;-)

So good eyes, but I believe that this really does reflect the ancient
code...

On the other hand, would you have ideas for more modern replacement
examples?

							Thanx, Paul

> ---
>  Documentation/RCU/listRCU.txt | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/Documentation/RCU/listRCU.txt b/Documentation/RCU/listRCU.txt
> index adb5a3782846..190e666fc359 100644
> --- a/Documentation/RCU/listRCU.txt
> +++ b/Documentation/RCU/listRCU.txt
> @@ -175,7 +175,7 @@ otherwise, the added fields would need to be filled in):
>  		list_for_each_entry(e, list, list) {
>  			if (!audit_compare_rule(rule, &e->rule)) {
>  				e->rule.action = newaction;
> -				e->rule.file_count = newfield_count;
> +				e->rule.field_count = newfield_count;
>  				write_unlock(&auditsc_lock);
>  				return 0;
>  			}
> @@ -204,7 +204,7 @@ RCU ("read-copy update") its name.  The RCU code is as follows:
>  					return -ENOMEM;
>  				audit_copy_rule(&ne->rule, &e->rule);
>  				ne->rule.action = newaction;
> -				ne->rule.file_count = newfield_count;
> +				ne->rule.field_count = newfield_count;
>  				list_replace_rcu(&e->list, &ne->list);
>  				call_rcu(&e->rcu, audit_free_rule);
>  				return 0;
> -- 
> 2.21.0.1020.gf2820cf01a-goog
> 

Powered by blists - more mailing lists