[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <20190507135135.AFDCC60E3E@smtp.codeaurora.org>
Date: Tue, 7 May 2019 13:51:35 +0000 (UTC)
From: Kalle Valo <kvalo@...eaurora.org>
To: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Cc: "David S. Miller" <davem@...emloft.net>,
ath10k@...ts.infradead.org, linux-wireless@...r.kernel.org,
netdev@...r.kernel.org, linux-kernel@...r.kernel.org,
"Gustavo A. R. Silva" <gustavo@...eddedor.com>
Subject: Re: [PATCH][next] ath10k: Use struct_size() helper
"Gustavo A. R. Silva" <gustavo@...eddedor.com> wrote:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes, in particular in the
> context in which this code is being used.
>
> So, change the following form:
>
> sizeof(*rx) + (sizeof(struct htt_rx_indication_mpdu_range) * num_mpdu_ranges)
>
> to :
>
> struct_size(rx, mpdu_ranges, num_mpdu_ranges)
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>
> Signed-off-by: Kalle Valo <kvalo@...eaurora.org>
Patch applied to ath-next branch of ath.git, thanks.
35b50e70df27 ath10k: Use struct_size() helper
--
https://patchwork.kernel.org/patch/10884271/
https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches
Powered by blists - more mailing lists