[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <c5d74c72-b54f-de22-43b4-8723518bdc0d@linux.alibaba.com>
Date: Fri, 10 May 2019 08:41:34 -0700
From: Yang Shi <yang.shi@...ux.alibaba.com>
To: "Huang, Ying" <ying.huang@...el.com>
Cc: hannes@...xchg.org, mhocko@...e.com, mgorman@...hsingularity.net,
kirill.shutemov@...ux.intel.com, hughd@...gle.com,
akpm@...ux-foundation.org, linux-mm@...ck.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH] mm: vmscan: correct nr_reclaimed for THP
On 5/9/19 8:03 PM, Huang, Ying wrote:
> Yang Shi <yang.shi@...ux.alibaba.com> writes:
>
>> On 5/9/19 7:12 PM, Huang, Ying wrote:
>>> Yang Shi <yang.shi@...ux.alibaba.com> writes:
>>>
>>>> Since commit bd4c82c22c36 ("mm, THP, swap: delay splitting THP after
>>>> swapped out"), THP can be swapped out in a whole. But, nr_reclaimed
>>>> still gets inc'ed by one even though a whole THP (512 pages) gets
>>>> swapped out.
>>>>
>>>> This doesn't make too much sense to memory reclaim. For example, direct
>>>> reclaim may just need reclaim SWAP_CLUSTER_MAX pages, reclaiming one THP
>>>> could fulfill it. But, if nr_reclaimed is not increased correctly,
>>>> direct reclaim may just waste time to reclaim more pages,
>>>> SWAP_CLUSTER_MAX * 512 pages in worst case.
>>>>
>>>> This change may result in more reclaimed pages than scanned pages showed
>>>> by /proc/vmstat since scanning one head page would reclaim 512 base pages.
>>>>
>>>> Cc: "Huang, Ying" <ying.huang@...el.com>
>>>> Cc: Johannes Weiner <hannes@...xchg.org>
>>>> Cc: Michal Hocko <mhocko@...e.com>
>>>> Cc: Mel Gorman <mgorman@...hsingularity.net>
>>>> Cc: "Kirill A . Shutemov" <kirill.shutemov@...ux.intel.com>
>>>> Cc: Hugh Dickins <hughd@...gle.com>
>>>> Signed-off-by: Yang Shi <yang.shi@...ux.alibaba.com>
>>>> ---
>>>> I'm not quite sure if it was the intended behavior or just omission. I tried
>>>> to dig into the review history, but didn't find any clue. I may miss some
>>>> discussion.
>>>>
>>>> mm/vmscan.c | 6 +++++-
>>>> 1 file changed, 5 insertions(+), 1 deletion(-)
>>>>
>>>> diff --git a/mm/vmscan.c b/mm/vmscan.c
>>>> index fd9de50..7e026ec 100644
>>>> --- a/mm/vmscan.c
>>>> +++ b/mm/vmscan.c
>>>> @@ -1446,7 +1446,11 @@ static unsigned long shrink_page_list(struct list_head *page_list,
>>>> unlock_page(page);
>>>> free_it:
>>>> - nr_reclaimed++;
>>>> + /*
>>>> + * THP may get swapped out in a whole, need account
>>>> + * all base pages.
>>>> + */
>>>> + nr_reclaimed += (1 << compound_order(page));
>>>> /*
>>>> * Is there need to periodically free_page_list? It would
>>> Good catch! Thanks!
>>>
>>> How about to change this to
>>>
>>>
>>> nr_reclaimed += hpage_nr_pages(page);
>> Either is fine to me. Is this faster than "1 << compound_order(page)"?
> I think the readability is a little better. And this will become
>
> nr_reclaimed += 1
>
> if CONFIG_TRANSPARENT_HUAGEPAGE is disabled.
Good point. Will update in v2 soon.
>
> Best Regards,
> Huang, Ying
>
>>> Best Regards,
>>> Huang, Ying
Powered by blists - more mailing lists