[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <7bd46e20c28f8f0a1b7b4ba49c151860bf6c58f1.camel@perches.com>
Date: Thu, 30 May 2019 04:53:24 -0700
From: Joe Perches <joe@...ches.com>
To: David Laight <David.Laight@...LAB.COM>,
'Alexey Dobriyan' <adobriyan@...il.com>,
"akpm@...ux-foundation.org" <akpm@...ux-foundation.org>
Cc: "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
Subject: Re: [PATCH 1/2] add typeof_member() macro
On Thu, 2019-05-30 at 11:37 +0000, David Laight wrote:
> From: Alexey Dobriyan
> > Sent: 29 May 2019 20:07
> >
> > Add typeof_member() macro so that types can be exctracted without
> > introducing dummy variables.
> >
> > Signed-off-by: Alexey Dobriyan <adobriyan@...il.com>
> > ---
> >
> > include/linux/kernel.h | 2 ++
> > 1 file changed, 2 insertions(+)
> >
> > --- a/include/linux/kernel.h
> > +++ b/include/linux/kernel.h
> > @@ -88,6 +88,8 @@
> > */
> > #define FIELD_SIZEOF(t, f) (sizeof(((t*)0)->f))
> >
> > +#define typeof_member(T, m) typeof(((T*)0)->m)
>
> Should probably be 't' (not 'T') and upper case ?
>
> Hmmm.... the #define is longer that what it expands to ...
While I did object to the avoidance in the obvious
misnaming of FIELD_SIZEOF, this could reasonably
be named FIELD_TYPEOF for symmetry.
Powered by blists - more mailing lists