lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 30 May 2019 14:30:01 -0400
From:   Dennis Dalessandro <dennis.dalessandro@...el.com>
To:     "Gustavo A. R. Silva" <gustavo@...eddedor.com>,
        Mike Marciniszyn <mike.marciniszyn@...el.com>,
        Doug Ledford <dledford@...hat.com>,
        Jason Gunthorpe <jgg@...pe.ca>
Cc:     linux-rdma@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH][next] IB/hfi1: Use struct_size() helper

On 5/29/2019 11:15 AM, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes, in particular in the
> context in which this code is being used.
> 
> So, replace the following form:
> 
> sizeof(struct opa_port_status_rsp) + num_vls * sizeof(struct _vls_pctrs)
> 
> with:
> 
> struct_size(rsp, vls, num_vls)
> 
> and so on...
> 
> Also, notice that variable size is unnecessary, hence it is removed.
> 
> This code was detected with the help of Coccinelle.
> 
> Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>
> ---
>   drivers/infiniband/hw/hfi1/mad.c | 9 +++------
>   1 file changed, 3 insertions(+), 6 deletions(-)
> 
> diff --git a/drivers/infiniband/hw/hfi1/mad.c b/drivers/infiniband/hw/hfi1/mad.c
> index 4228393e6c4c..184dba3c2828 100644
> --- a/drivers/infiniband/hw/hfi1/mad.c
> +++ b/drivers/infiniband/hw/hfi1/mad.c
> @@ -2744,8 +2744,7 @@ static int pma_get_opa_portstatus(struct opa_pma_mad *pmp,
>   	u16 link_width;
>   	u16 link_speed;
>   
> -	response_data_size = sizeof(struct opa_port_status_rsp) +
> -				num_vls * sizeof(struct _vls_pctrs);
> +	response_data_size = struct_size(rsp, vls, num_vls);
>   	if (response_data_size > sizeof(pmp->data)) {
>   		pmp->mad_hdr.status |= OPA_PM_STATUS_REQUEST_TOO_LARGE;
>   		return reply((struct ib_mad_hdr *)pmp);
> @@ -3014,8 +3013,7 @@ static int pma_get_opa_datacounters(struct opa_pma_mad *pmp,
>   	}
>   
>   	/* Sanity check */
> -	response_data_size = sizeof(struct opa_port_data_counters_msg) +
> -				num_vls * sizeof(struct _vls_dctrs);
> +	response_data_size = struct_size(req, port[0].vls, num_vls);
>   
>   	if (response_data_size > sizeof(pmp->data)) {
>   		pmp->mad_hdr.status |= IB_SMP_INVALID_FIELD;
> @@ -3232,8 +3230,7 @@ static int pma_get_opa_porterrors(struct opa_pma_mad *pmp,
>   		return reply((struct ib_mad_hdr *)pmp);
>   	}
>   
> -	response_data_size = sizeof(struct opa_port_error_counters64_msg) +
> -				num_vls * sizeof(struct _vls_ectrs);
> +	response_data_size = struct_size(req, port[0].vls, num_vls);
>   
>   	if (response_data_size > sizeof(pmp->data)) {
>   		pmp->mad_hdr.status |= IB_SMP_INVALID_FIELD;
> 

Reviewed-by: Dennis Dalessandro <dennis.dalessandro@...el.com>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ