lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 6 Jun 2019 20:05:57 +0200
From:   Jessica Yu <jeyu@...nel.org>
To:     "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Cc:     linux-kernel@...r.kernel.org
Subject: Re: [PATCH] kernel: module: Use struct_size() helper

+++ Gustavo A. R. Silva [04/06/19 18:23 -0500]:
>Make use of the struct_size() helper instead of an open-coded version
>in order to avoid any potential type mistakes, in particular in the
>context in which this code is being used.
>
>So, replace the following form:
>
>sizeof(*sect_attrs) + nloaded * sizeof(sect_attrs->attrs[0]
>
>with:
>
>struct_size(sect_attrs, attrs, nloaded)
>
>This code was detected with the help of Coccinelle.
>
>Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>

Hi Gustavo!

I see you've sent similar cleanup patches elsewhere, do you think you
could reword your commit message to be more similar to your patch here
for instance:

	https://lkml.org/lkml/2019/6/5/856

It does a *much* better job of explaining the motivation and usage of
struct_size().

Thank you!

Jessica

>---
> kernel/module.c | 3 +--
> 1 file changed, 1 insertion(+), 2 deletions(-)
>
>diff --git a/kernel/module.c b/kernel/module.c
>index 80c7c09584cf..3f3bb090fbf4 100644
>--- a/kernel/module.c
>+++ b/kernel/module.c
>@@ -1492,8 +1492,7 @@ static void add_sect_attrs(struct module *mod, const struct load_info *info)
> 	for (i = 0; i < info->hdr->e_shnum; i++)
> 		if (!sect_empty(&info->sechdrs[i]))
> 			nloaded++;
>-	size[0] = ALIGN(sizeof(*sect_attrs)
>-			+ nloaded * sizeof(sect_attrs->attrs[0]),
>+	size[0] = ALIGN(struct_size(sect_attrs, attrs, nloaded),
> 			sizeof(sect_attrs->grp.attrs[0]));
> 	size[1] = (nloaded + 1) * sizeof(sect_attrs->grp.attrs[0]);
> 	sect_attrs = kzalloc(size[0] + size[1], GFP_KERNEL);
>-- 
>2.21.0
>

Powered by blists - more mailing lists