[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <75ceb6d5-9717-3945-364b-f2374a705697@arm.com>
Date: Tue, 11 Jun 2019 15:35:30 +0100
From: Jean-Philippe Brucker <jean-philippe.brucker@....com>
To: Jonathan Cameron <jonathan.cameron@...wei.com>
Cc: mark.rutland@....com, devicetree@...r.kernel.org,
will.deacon@....com, linux-kernel@...r.kernel.org,
iommu@...ts.linux-foundation.org, robh+dt@...nel.org,
robin.murphy@....com, linux-arm-kernel@...ts.infradead.org
Subject: Re: [PATCH 4/8] iommu/arm-smmu-v3: Add support for Substream IDs
On 11/06/2019 11:19, Jonathan Cameron wrote:
>> +static int arm_smmu_alloc_cd_tables(struct arm_smmu_domain *smmu_domain,
>> + struct arm_smmu_master *master)
>> +{
>> + struct arm_smmu_device *smmu = smmu_domain->smmu;
>> + struct arm_smmu_s1_cfg *cfg = &smmu_domain->s1_cfg;
>>
>> - cfg->cdptr[0] = cpu_to_le64(val);
>> + cfg->s1fmt = STRTAB_STE_0_S1FMT_LINEAR;
>> + cfg->s1cdmax = master->ssid_bits;
>> + return arm_smmu_alloc_cd_leaf_table(smmu, &cfg->table, 1 << cfg->s1cdmax);
>> +}
>>
>> - val = cfg->cd.ttbr & CTXDESC_CD_1_TTB0_MASK;
>> - cfg->cdptr[1] = cpu_to_le64(val);
>
> Hmm. Diff was having a field day in trying to make the patch as unreadable as possible..
Ugh, yes. This part is a bit more readable with --patience, but I'll
also try to split the patch as you suggest
Thanks,
Jean
Powered by blists - more mailing lists