lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 13 Jun 2019 14:12:08 -0500
From:   Josh Poimboeuf <jpoimboe@...hat.com>
To:     Song Liu <songliubraving@...com>
Cc:     X86 ML <x86@...nel.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
        Alexei Starovoitov <ast@...nel.org>,
        Daniel Borkmann <daniel@...earbox.net>,
        "netdev@...r.kernel.org" <netdev@...r.kernel.org>,
        "bpf@...r.kernel.org" <bpf@...r.kernel.org>,
        Peter Zijlstra <peterz@...radead.org>,
        Kairui Song <kasong@...hat.com>
Subject: Re: [PATCH 3/9] x86/bpf: Move epilogue generation to a dedicated
 function

On Thu, Jun 13, 2019 at 06:57:10PM +0000, Song Liu wrote:
> 
> 
> > On Jun 13, 2019, at 6:21 AM, Josh Poimboeuf <jpoimboe@...hat.com> wrote:
> > 
> > Improve code readability by moving the BPF JIT function epilogue
> > generation code to a dedicated emit_epilogue() function, analagous to
> > the existing emit_prologue() function.
> > 
> > Signed-off-by: Josh Poimboeuf <jpoimboe@...hat.com>
> > ---
> > arch/x86/net/bpf_jit_comp.c | 37 ++++++++++++++++++++++++-------------
> > 1 file changed, 24 insertions(+), 13 deletions(-)
> > 
> > diff --git a/arch/x86/net/bpf_jit_comp.c b/arch/x86/net/bpf_jit_comp.c
> > index 32bfab4e21eb..da8c988b0f0f 100644
> > --- a/arch/x86/net/bpf_jit_comp.c
> > +++ b/arch/x86/net/bpf_jit_comp.c
> > @@ -240,6 +240,28 @@ static void emit_prologue(u8 **pprog, u32 stack_depth, bool ebpf_from_cbpf)
> > 	*pprog = prog;
> > }
> > 
> > +static void emit_epilogue(u8 **pprog)
> > +{
> > +	u8 *prog = *pprog;
> > +	int cnt = 0;
> > +
> > +	/* mov rbx, qword ptr [rbp+0] */
> > +	EMIT4(0x48, 0x8B, 0x5D, 0);
> > +	/* mov r13, qword ptr [rbp+8] */
> > +	EMIT4(0x4C, 0x8B, 0x6D, 8);
> > +	/* mov r14, qword ptr [rbp+16] */
> > +	EMIT4(0x4C, 0x8B, 0x75, 16);
> > +	/* mov r15, qword ptr [rbp+24] */
> > +	EMIT4(0x4C, 0x8B, 0x7D, 24);
> 
> Shall we update these comments to AT&T syntax? 

Yes, but they're updated with all the others in patch 8.

-- 
Josh

Powered by blists - more mailing lists