[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAFLxGvyGFtacE3mgZ03zrOeF2S24KdtGj+Qy-3kmA2wbRhNJYQ@mail.gmail.com>
Date: Tue, 18 Jun 2019 00:15:14 +0200
From: Richard Weinberger <richard.weinberger@...il.com>
To: Kamal Dasu <kdasu.kdev@...il.com>
Cc: linux-mtd@...ts.infradead.org,
Vignesh Raghavendra <vigneshr@...com>,
Richard Weinberger <richard@....at>,
LKML <linux-kernel@...r.kernel.org>,
Marek Vasut <marek.vasut@...il.com>,
bcm-kernel-feedback-list@...adcom.com,
Miquel Raynal <miquel.raynal@...tlin.com>,
Brian Norris <computersforpeace@...il.com>,
David Woodhouse <dwmw2@...radead.org>
Subject: Re: [PATCH v3 1/2] mtd: Add flag to indicate panic_write
On Fri, May 17, 2019 at 10:08 AM Richard Weinberger
<richard.weinberger@...il.com> wrote:
>
> On Thu, May 16, 2019 at 6:42 PM Kamal Dasu <kdasu.kdev@...il.com> wrote:
> >
> > Added a flag to indicate a panic_write so that low level drivers can
> > use it to take required action where applicable, to ensure oops data
> > gets written to assigned mtd device.
> >
> > Signed-off-by: Kamal Dasu <kdasu.kdev@...il.com>
> > ---
> > drivers/mtd/mtdcore.c | 3 +++
> > include/linux/mtd/mtd.h | 6 ++++++
> > 2 files changed, 9 insertions(+)
> >
> > diff --git a/drivers/mtd/mtdcore.c b/drivers/mtd/mtdcore.c
> > index 76b4264..a83decd 100644
> > --- a/drivers/mtd/mtdcore.c
> > +++ b/drivers/mtd/mtdcore.c
> > @@ -1138,6 +1138,9 @@ int mtd_panic_write(struct mtd_info *mtd, loff_t to, size_t len, size_t *retlen,
> > return -EROFS;
> > if (!len)
> > return 0;
> > + if (!mtd->oops_panic_write)
> > + mtd->oops_panic_write = true;
> > +
>
> You can set the flag unconditionally.
> If it is set, it will stay so, and setting it again, won't hurt.
>
> > return mtd->_panic_write(mtd, to, len, retlen, buf);
> > }
> > EXPORT_SYMBOL_GPL(mtd_panic_write);
> > diff --git a/include/linux/mtd/mtd.h b/include/linux/mtd/mtd.h
> > index 677768b..791c34d 100644
> > --- a/include/linux/mtd/mtd.h
> > +++ b/include/linux/mtd/mtd.h
> > @@ -330,6 +330,12 @@ struct mtd_info {
> > int (*_get_device) (struct mtd_info *mtd);
> > void (*_put_device) (struct mtd_info *mtd);
> >
> > + /*
> > + * flag indicates a panic write, low level drivers can take appropriate
> > + * action if required to ensure writes go through
> > + */
> > + bool oops_panic_write;
> > +
>
> Maybe we find a better name for it.
> panic_write_triggered?
ping?
I'm happy with the overall approach.
So let's target the upcoming merge window.
Can you please sort my two comments out? :-)
--
Thanks,
//richard
Powered by blists - more mailing lists