[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAKwvOd=i2qsEO90cHn-Zvgd7vbhK5Z4RH89gJGy=Cjzbi9QRMA@mail.gmail.com>
Date: Tue, 18 Jun 2019 16:23:43 -0700
From: Nick Desaulniers <ndesaulniers@...gle.com>
To: Matthias Kaehlcke <mka@...omium.org>
Cc: "David S . Miller" <davem@...emloft.net>,
Alexey Kuznetsov <kuznet@....inr.ac.ru>,
Hideaki YOSHIFUJI <yoshfuji@...ux-ipv6.org>,
Alexander Duyck <alexander.h.duyck@...hat.com>,
netdev@...r.kernel.org, LKML <linux-kernel@...r.kernel.org>,
Douglas Anderson <dianders@...omium.org>,
Nathan Huckleberry <nhuck@...gle.com>,
clang-built-linux <clang-built-linux@...glegroups.com>,
Nathan Chancellor <natechancellor@...il.com>
Subject: Re: [PATCH] net/ipv4: fib_trie: Avoid cryptic ternary expressions
On Tue, Jun 18, 2019 at 4:04 PM Nathan Chancellor
<natechancellor@...il.com> wrote:
>
> On Tue, Jun 18, 2019 at 02:14:40PM -0700, Matthias Kaehlcke wrote:
> > empty_child_inc/dec() use the ternary operator for conditional
> > operations. The conditions involve the post/pre in/decrement
> > operator and the operation is only performed when the condition
> > is *not* true. This is hard to parse for humans, use a regular
> > 'if' construct instead and perform the in/decrement separately.
> >
> > This also fixes two warnings that are emitted about the value
> > of the ternary expression being unused, when building the kernel
> > with clang + "kbuild: Remove unnecessary -Wno-unused-value"
> > (https://lore.kernel.org/patchwork/patch/1089869/):
> >
> > CC net/ipv4/fib_trie.o
> > net/ipv4/fib_trie.c:351:2: error: expression result unused [-Werror,-Wunused-value]
> > ++tn_info(n)->empty_children ? : ++tn_info(n)->full_children;
> >
>
> As an FYI, this is also being fixed in clang:
>
> https://bugs.llvm.org/show_bug.cgi?id=42239
>
> https://reviews.llvm.org/D63369
While I'm glad we found and fixed a bug in Clang; I'm still for fixing
the underlying code from a readability perspective. If it takes
longer than a few seconds to understand a statement to the non-author,
the code as written may be too clever.
As a side note, I'm going to try to see if MAINTAINERS and
scripts/get_maintainers.pl supports regexes on the commit messages in
order to cc our mailing list (clang-built-linux
<clang-built-linux@...glegroups.com>) automatically; but in the
meantime please try to remember to cc the list manually. I usually
find it quickly from the bookmarked https://clangbuiltlinux.github.io/
which lists it there) (but I should still automate this).
>
> > Signed-off-by: Matthias Kaehlcke <mka@...omium.org>
> > ---
> > I have no good understanding of the fib_trie code, but the
> > disentangled code looks wrong, and it should be equivalent to the
> > cryptic version, unless I messed it up. In empty_child_inc()
> > 'full_children' is only incremented when 'empty_children' is -1. I
> > suspect a bug in the cryptic code, but am surprised why it hasn't
> > blown up yet. Or is it intended behavior that is just
> > super-counterintuitive?
> >
> > For now I'm leaving it at disentangling the cryptic expressions,
> > if there is a bug we can discuss what action to take.
> > ---
> > net/ipv4/fib_trie.c | 10 ++++++++--
> > 1 file changed, 8 insertions(+), 2 deletions(-)
> >
> > diff --git a/net/ipv4/fib_trie.c b/net/ipv4/fib_trie.c
> > index 868c74771fa9..cf7788e336b7 100644
> > --- a/net/ipv4/fib_trie.c
> > +++ b/net/ipv4/fib_trie.c
> > @@ -338,12 +338,18 @@ static struct tnode *tnode_alloc(int bits)
> >
> > static inline void empty_child_inc(struct key_vector *n)
> > {
> > - ++tn_info(n)->empty_children ? : ++tn_info(n)->full_children;
> > + tn_info(n)->empty_children++;
> > +
> > + if (!tn_info(n)->empty_children)
> > + tn_info(n)->full_children++;
> > }
> >
> > static inline void empty_child_dec(struct key_vector *n)
> > {
> > - tn_info(n)->empty_children-- ? : tn_info(n)->full_children--;
> > + if (!tn_info(n)->empty_children)
> > + tn_info(n)->full_children--;
> > +
> > + tn_info(n)->empty_children--;
This change looks correct to me, so thanks for the patch and:
Reviewed-by: Nick Desaulniers <ndesaulniers@...gle.com>
(Bikeshed; I prefer pre-inc/dec to post-inc/dec unless you really care
about the previous value. Should be irrelevant with a sufficiently
smart compiler though. ;) )
--
Thanks,
~Nick Desaulniers
Powered by blists - more mailing lists