[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <20190625050155.537F1607C3@smtp.codeaurora.org>
Date: Tue, 25 Jun 2019 05:01:55 +0000 (UTC)
From: Kalle Valo <kvalo@...eaurora.org>
To: "Gustavo A. R. Silva" <gustavo@...eddedor.com>
Cc: Igor Mitsyanko <imitsyanko@...ntenna.com>,
Avinash Patil <avinashp@...ntenna.com>,
Sergey Matyukevich <smatyukevich@...ntenna.com>,
"David S. Miller" <davem@...emloft.net>,
linux-wireless@...r.kernel.org, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org,
"Gustavo A. R. Silva" <gustavo@...eddedor.com>
Subject: Re: [PATCH][next] qtnfmac: Use struct_size() in kzalloc()
"Gustavo A. R. Silva" <gustavo@...eddedor.com> wrote:
> One of the more common cases of allocation size calculations is finding
> the size of a structure that has a zero-sized array at the end, along
> with memory for some number of elements for that array. For example:
>
> struct ieee80211_regdomain {
> ...
> struct ieee80211_reg_rule reg_rules[];
> };
>
> instance = kzalloc(sizeof(*mac->rd) +
> sizeof(struct ieee80211_reg_rule) *
> count, GFP_KERNEL);
>
> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:
>
> instance = kzalloc(struct_size(instance, reg_rules, count), GFP_KERNEL);
>
> This code was detected with the help of Coccinelle.
>
> Signed-off-by: Gustavo A. R. Silva <gustavo@...eddedor.com>
> Reviewed-by: Sergey Matyukevich <sergey.matyukevich.os@...ntenna.com>
Patch applied to wireless-drivers-next.git, thanks.
9a1ace64ca3b qtnfmac: Use struct_size() in kzalloc()
--
https://patchwork.kernel.org/patch/10982675/
https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches
Powered by blists - more mailing lists