[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190626073531.8946-4-fabian.krueger@fau.de>
Date: Wed, 26 Jun 2019 09:35:21 +0200
From: Fabian Krueger <fabian.krueger@....de>
To: unlisted-recipients:; (no To-header on input)
CC: <fabian.krueger@....de>,
Michael Scheiderer <michael.scheiderer@....de>,
<linux-kernel@...cs.fau.de>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
<devel@...verdev.osuosl.org>, <linux-kernel@...r.kernel.org>
Subject: [PATCH 3/8] staging: kpc2000: introduce usage of __packed
Replaced __attribute__((packed)) with __packed. Both ways of attributing
are equivalent, but being shorter, __packed should be preferred.
This refactoring makes the core more readable.
Signed-off-by: Fabian Krueger <fabian.krueger@....de>
Signed-off-by: Michael Scheiderer <michael.scheiderer@....de>
Cc: <linux-kernel@...cs.fau.de>
---
drivers/staging/kpc2000/kpc2000_spi.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/kpc2000/kpc2000_spi.c b/drivers/staging/kpc2000/kpc2000_spi.c
index c8fdb7e868f8..42d32de2230e 100644
--- a/drivers/staging/kpc2000/kpc2000_spi.c
+++ b/drivers/staging/kpc2000/kpc2000_spi.c
@@ -114,7 +114,7 @@ struct kp_spi_controller_state {
union kp_spi_config {
/* use this to access individual elements */
- struct __attribute__((packed)) spi_config_bitfield {
+ struct __packed spi_config_bitfield {
unsigned int pha : 1; /* spim_clk Phase */
unsigned int pol : 1; /* spim_clk Polarity */
unsigned int epol : 1; /* spim_csx Polarity */
@@ -133,7 +133,7 @@ union kp_spi_config {
};
union kp_spi_status {
- struct __attribute__((packed)) spi_status_bitfield {
+ struct __packed spi_status_bitfield {
unsigned int rx : 1; /* Rx Status */
unsigned int tx : 1; /* Tx Status */
unsigned int eo : 1; /* End of Transfer */
@@ -148,7 +148,7 @@ union kp_spi_status {
};
union kp_spi_ffctrl {
- struct __attribute__((packed)) spi_ffctrl_bitfield {
+ struct __packed spi_ffctrl_bitfield {
unsigned int ffstart : 1; /* FIFO Start */
unsigned int : 31;
} bitfield;
--
2.17.1
Powered by blists - more mailing lists