[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-Id: <20190702131348.9004db6da7e1cbeb7db5ca9f@linux-foundation.org>
Date: Tue, 2 Jul 2019 13:13:48 -0700
From: Andrew Morton <akpm@...ux-foundation.org>
To: Matteo Croce <mcroce@...hat.com>
Cc: Alexey Dobriyan <adobriyan@...il.com>,
LKML <linux-kernel@...r.kernel.org>,
Kees Cook <keescook@...omium.org>,
Aaron Tomlin <atomlin@...hat.com>
Subject: Re: [PATCH] proc/sysctl: add shared variables for range check
On Tue, 2 Jul 2019 19:21:33 +0200 Matteo Croce <mcroce@...hat.com> wrote:
> On Tue, Jul 2, 2019 at 7:13 PM Alexey Dobriyan <adobriyan@...il.com> wrote:
> >
> > > -static long zero;
> > > static long long_max = LONG_MAX;
> > >
> > > struct ctl_table epoll_table[] = {
> > > @@ -301,7 +300,7 @@ struct ctl_table epoll_table[] = {
> > > .maxlen = sizeof(max_user_watches),
> > > .mode = 0644,
> > > .proc_handler = proc_doulongvec_minmax,
> > > - .extra1 = &zero,
> > > + .extra1 = SYSCTL_ZERO,
> > > .extra2 = &long_max,
> >
> > This looks wrong: proc_doulongvec_minmax() expects "long"s.
> > The whole patch needs rechecking.
> >
> > > +/* shared constants to be used in various sysctls */
> > > +const =======>int<========== sysctl_vals[] = { 0, 1, INT_MAX };
> > > +EXPORT_SYMBOL(sysctl_vals);
>
> Yes, you're right, that chunk must be dropped.
> Anyway I've checked the patch, this was the only long field touched.
Yup.
akpm3:/usr/src/25> find . -name "*.c" | xargs grep -C4 SYSCTL_ZERO|grep long
./fs/eventpoll.c- .proc_handler = proc_doulongvec_minmax,
./fs/eventpoll.c- .extra2 = &long_max,
I did this:
--- a/fs/eventpoll.c~proc-sysctl-add-shared-variables-for-range-check-fix-4
+++ a/fs/eventpoll.c
@@ -291,6 +291,7 @@ static LIST_HEAD(tfile_check_list);
#include <linux/sysctl.h>
+static long long_zero;
static long long_max = LONG_MAX;
struct ctl_table epoll_table[] = {
@@ -300,7 +301,7 @@ struct ctl_table epoll_table[] = {
.maxlen = sizeof(max_user_watches),
.mode = 0644,
.proc_handler = proc_doulongvec_minmax,
- .extra1 = SYSCTL_ZERO,
+ .extra1 = &long_zero,
.extra2 = &long_max,
},
{ }
I renamed it to avoid using "&zero," in this situation.
Powered by blists - more mailing lists