[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20190703175845.GA68011@archlinux-epyc>
Date: Wed, 3 Jul 2019 10:58:45 -0700
From: Nathan Chancellor <natechancellor@...il.com>
To: Arnd Bergmann <arnd@...db.de>
Cc: Ingo Molnar <mingo@...hat.com>,
Peter Zijlstra <peterz@...radead.org>,
Andrew Morton <akpm@...ux-foundation.org>,
linux-kernel@...r.kernel.org, clang-built-linux@...glegroups.com
Subject: Re: [PATCH] waitqueue: fix clang -Wuninitialized warnings
On Wed, Jul 03, 2019 at 10:10:55AM +0200, Arnd Bergmann wrote:
> When CONFIG_LOCKDEP is set, every use of DECLARE_WAIT_QUEUE_HEAD_ONSTACK()
> produces an annoying warning from clang, which is particularly annoying
> for allmodconfig builds:
>
> fs/namei.c:1646:34: error: variable 'wq' is uninitialized when used within its own initialization [-Werror,-Wuninitialized]
> DECLARE_WAIT_QUEUE_HEAD_ONSTACK(wq);
> ^~
> include/linux/wait.h:74:63: note: expanded from macro 'DECLARE_WAIT_QUEUE_HEAD_ONSTACK'
> struct wait_queue_head name = __WAIT_QUEUE_HEAD_INIT_ONSTACK(name)
> ~~~~ ^~~~
> include/linux/wait.h:72:33: note: expanded from macro '__WAIT_QUEUE_HEAD_INIT_ONSTACK'
> ({ init_waitqueue_head(&name); name; })
> ^~~~
>
> After playing with it for a while, I have found a way to rephrase the
> macro in a way that should work well with both gcc and clang and not
> produce this warning. The open-coded __WAIT_QUEUE_HEAD_INIT_ONSTACK
> is a little more verbose than the original version by Peter Zijlstra,
> but avoids the gcc-ism that suppresses warnings when assigning a
> variable to itself.
>
> Cc: Peter Zijlstra <peterz@...radead.org>
> Signed-off-by: Arnd Bergmann <arnd@...db.de>
Thank you for sending the fix for these warnings, they are the last
major ones that I can see across various defconfig and allyesconfig
testing. This resolves all of them.
Reviewed-by: Nathan Chancellor <natechancellor@...il.com>
Tested-by: Nathan Chancellor <natechancellor@...il.com>
Powered by blists - more mailing lists