lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 4 Jul 2019 15:06:01 +0200
From:   Boris Brezillon <boris.brezillon@...labora.com>
To:     Ezequiel Garcia <ezequiel@...labora.com>
Cc:     Nicolas Dufresne <nicolas.dufresne@...labora.com>,
        linux-media@...r.kernel.org, Hans Verkuil <hans.verkuil@...co.com>,
        kernel@...labora.com, Tomasz Figa <tfiga@...omium.org>,
        linux-rockchip@...ts.infradead.org,
        Heiko Stuebner <heiko@...ech.de>,
        Jonas Karlman <jonas@...boo.se>,
        Philipp Zabel <p.zabel@...gutronix.de>,
        Paul Kocialkowski <paul.kocialkowski@...tlin.com>,
        Alexandre Courbot <acourbot@...omium.org>,
        fbuergisser@...omium.org, linux-kernel@...r.kernel.org,
        Pawel Osciak <posciak@...omium.org>
Subject: Re: [PATCH v2 1/2] media: uapi: Add VP8 stateless decoder API

On Thu, 04 Jul 2019 10:00:33 -0300
Ezequiel Garcia <ezequiel@...labora.com> wrote:


> 
> Oops, this is just an internal note, it seems I forgot to remove this one.
> 
> > I am right to think that this is basically the size in bits of the
> > frame header ? Maybe it could be another way to formulate it ? I'm just
> > trying to think of formulation that will better guide the developers
> > implementing the parser feeding this. You basically need to parse the
> > header to get this size (as everything is dynamically sized).
> >   
> 
> Depending what you call "frame header", then yes, it's the size in bits.
> 
>                              first_part_size          parttion_sizes[0]
>                                 ^                     ^
>                                 |                     |
>                        +--------+------+        +-----+-----+
>                        | control part  |        |           |
>    +--------+----------------+------------------+-----------+-----+-----------+
>    | tag 3B | extra 7B | hdr | mb_data | dct sz | dct part0 | ... | dct partn |
>    +--------+-----------------------------------+-----------+-----+-----------+
> 
> The above shows a VP8 frame, "macroblock_bit_offset" is the size in bits of
> the "hdr" portion: i.e. the header of the first partition (aka control partition).
> 
> Thinking about it, the current description is quite confusing.
> 
> How about:
> 
> "Size in bits of the frame header. In other words, this the size in bits of the header
> portion of the first partition".

How about having a similar diagram somewhere in the spec? It's usually
much clearer than a sentence, at least that's my opinion.

Powered by blists - more mailing lists