[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20190704133040.5623-1-lpf.vector@gmail.com>
Date: Thu, 4 Jul 2019 21:30:39 +0800
From: Pengfei Li <lpf.vector@...il.com>
To: akpm@...ux-foundation.org, peterz@...radead.org, urezki@...il.com
Cc: rpenyaev@...e.de, mhocko@...e.com, guro@...com,
aryabinin@...tuozzo.com, rppt@...ux.ibm.com, mingo@...nel.org,
rick.p.edgecombe@...el.com, linux-mm@...ck.org,
linux-kernel@...r.kernel.org, Pengfei Li <lpf.vector@...il.com>
Subject: [PATCH v3 0/1] mm/vmalloc.c: improve readability and rewrite vmap_area
v2 -> v3:
* patch 1-4: Abandoned
* patch 5:
- Eliminate "flags" (suggested by Uladzislau Rezki)
- Based on https://lkml.org/lkml/2019/6/6/455
and https://lkml.org/lkml/2019/7/3/661
v1 -> v2:
* patch 3: Rename __find_vmap_area to __search_va_in_busy_tree
instead of __search_va_from_busy_tree.
* patch 5: Add motivation and necessary test data to the commit
message.
* patch 5: Let va->flags use only some low bits of va_start
instead of completely overwriting va_start.
The current implementation of struct vmap_area wasted space.
After applying this commit, sizeof(struct vmap_area) has been
reduced from 11 words to 8 words.
Pengfei Li (1):
Modify struct vmap_area to reduce its size
include/linux/vmalloc.h | 20 +++++++++++++-------
mm/vmalloc.c | 24 ++++++++++--------------
2 files changed, 23 insertions(+), 21 deletions(-)
--
2.21.0
Powered by blists - more mailing lists