[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-Id: <9D5B6F33-6003-4CCA-BBE5-998B5A679B9C@oracle.com>
Date: Tue, 16 Jul 2019 10:53:02 -0400
From: Alex Kogan <alex.kogan@...cle.com>
To: Peter Zijlstra <peterz@...radead.org>
Cc: linux@...linux.org.uk, mingo@...hat.com, will.deacon@....com,
arnd@...db.de, longman@...hat.com, linux-arch@...r.kernel.org,
linux-arm-kernel@...ts.infradead.org, linux-kernel@...r.kernel.org,
tglx@...utronix.de, bp@...en8.de, hpa@...or.com, x86@...nel.org,
guohanjun@...wei.com, jglauber@...vell.com,
steven.sistare@...cle.com, daniel.m.jordan@...cle.com,
dave.dice@...cle.com, rahul.x.yadav@...cle.com
Subject: Re: [PATCH v3 2/5] locking/qspinlock: Refactor the qspinlock slow
path
On Jul 16, 2019, at 6:20 AM, Peter Zijlstra <peterz@...radead.org> wrote:
>
> On Mon, Jul 15, 2019 at 03:25:33PM -0400, Alex Kogan wrote:
>
>> +/*
>> + * set_locked_empty_mcs - Try to set the spinlock value to _Q_LOCKED_VAL,
>> + * and by doing that unlock the MCS lock when its waiting queue is empty
>> + * @lock: Pointer to queued spinlock structure
>> + * @val: Current value of the lock
>> + * @node: Pointer to the MCS node of the lock holder
>> + *
>> + * *,*,* -> 0,0,1
>> + */
>> +static __always_inline bool __set_locked_empty_mcs(struct qspinlock *lock,
>> + u32 val,
>> + struct mcs_spinlock *node)
>> +{
>> + return atomic_try_cmpxchg_relaxed(&lock->val, &val, _Q_LOCKED_VAL);
>> +}
>
> That name is nonsense. It should be something like:
>
> static __always_inline bool __try_clear_tail(…)
We already have set_locked(), so I was trying to convey the fact that we are
doing the same here, but only when the MCS chain is empty.
I can use __try_clear_tail() instead.
>
>
>> +/*
>> + * pass_mcs_lock - pass the MCS lock to the next waiter
>> + * @node: Pointer to the MCS node of the lock holder
>> + * @next: Pointer to the MCS node of the first waiter in the MCS queue
>> + */
>> +static __always_inline void __pass_mcs_lock(struct mcs_spinlock *node,
>> + struct mcs_spinlock *next)
>> +{
>> + arch_mcs_spin_unlock_contended(&next->locked, 1);
>> +}
>
> I'm not entirely happy with that name either; but it's not horrible like
> the other one. Why not mcs_spin_unlock_contended() ?
Sure, I can use mcs_spin_unlock_contended() instead.
Thanks,
— Alex
Powered by blists - more mailing lists