[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <300d3c06763883bc4af2d25d5466b7188d20e8f3.camel@perches.com>
Date: Sun, 21 Jul 2019 12:07:56 -0700
From: Joe Perches <joe@...ches.com>
To: Pawel Laszczak <pawell@...ence.com>, felipe.balbi@...ux.intel.com
Cc: gregkh@...uxfoundation.org, linux-usb@...r.kernel.org,
rogerq@...com, linux-kernel@...r.kernel.org, jbergsagel@...com,
nsekhar@...com, nm@...com, sureshp@...ence.com, jpawar@...ence.com,
kurahul@...ence.com, aniljoy@...ence.com
Subject: Re: [PATCH v10 3/6] usb:common Patch simplify
usb_decode_set_clear_feature function.
On Sun, 2019-07-21 at 19:32 +0100, Pawel Laszczak wrote:
> Patch adds usb_decode_test_mode and usb_decode_device_feature functions,
> which allow to make more readable and simplify the
> usb_decode_set_clear_feature function.
<chuckle> I need to read entire patch series before
commenting more I guess...
> Signed-off-by: Pawel Laszczak <pawell@...ence.com>
> ---
> drivers/usb/common/debug.c | 89 ++++++++++++++++++--------------------
> 1 file changed, 43 insertions(+), 46 deletions(-)
>
> diff --git a/drivers/usb/common/debug.c b/drivers/usb/common/debug.c
[]
> +static const char *usb_decode_device_feature(u16 wValue)
I believe this is still unnecessary hungarian.
> +{
> + switch (wValue) {
> + case USB_DEVICE_SELF_POWERED:
> + return "Self Powered";
> + case USB_DEVICE_REMOTE_WAKEUP:
> + return "Remote Wakeup";
> + case USB_DEVICE_TEST_MODE:
> + return "Test Mode";
> + case USB_DEVICE_U1_ENABLE:
> + return "U1 Enable";
> + case USB_DEVICE_U2_ENABLE:
> + return "U2 Enable";
> + case USB_DEVICE_LTM_ENABLE:
> + return "LTM Enable";
> + default:
> + return "UNKNOWN";
> + }
> +}
But yeah, exactly like this... ;)
Powered by blists - more mailing lists