lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20190722133724.GV9224@smile.fi.intel.com>
Date:   Mon, 22 Jul 2019 16:37:24 +0300
From:   Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To:     Yury Norov <yury.norov@...il.com>
Cc:     Andrew Morton <akpm@...ux-foundation.org>,
        Rasmus Villemoes <linux@...musvillemoes.dk>,
        Dmitry Torokhov <dmitry.torokhov@...il.com>,
        "David S . Miller" <davem@...emloft.net>,
        Stephen Rothwell <sfr@...b.auug.org.au>,
        Amritha Nambiar <amritha.nambiar@...el.com>,
        Willem de Bruijn <willemb@...gle.com>,
        Kees Cook <keescook@...omium.org>,
        Matthew Wilcox <willy@...radead.org>,
        "Tobin C . Harding" <tobin@...nel.org>,
        Will Deacon <will.deacon@....com>,
        Miklos Szeredi <mszeredi@...hat.com>,
        Vineet Gupta <vineet.gupta1@...opsys.com>,
        Chris Wilson <chris@...is-wilson.co.uk>,
        Arnaldo Carvalho de Melo <acme@...hat.com>,
        linux-kernel@...r.kernel.org, Yury Norov <ynorov@...vell.com>,
        Jens Axboe <axboe@...nel.dk>,
        Steffen Klassert <steffen.klassert@...unet.com>
Subject: Re: [PATCH 5/7] lib: rework bitmap_parse()

On Sun, Jul 21, 2019 at 02:27:51PM -0700, Yury Norov wrote:
> From Yury Norov <ynorov@...vell.com>
> 
> bitmap_parse() is ineffective and full of opaque variables and opencoded
> parts. It leads to hard understanding and usage of it. This rework
> includes:
>  - remove bitmap_shift_left() call from the cycle. Now it makes the
>    complexity of the algorithm as O(nbits^2). In the suggested approach
>    the input string is parsed in reverse direction, so no shifts needed;
>  - relax requirement on a single comma and no white spaces between chunks.
>    It is considered useful in scripting, and it aligns with
>    bitmap_parselist();
>  - split bitmap_parse() to small readable helpers;
>  - make an explicit calculation of the end of input line at the
>    beginning, so users of the bitmap_parse() won't bother doing this.

> Signed-off-by: Yury Norov <ynorov@...vell.com>
> Signed-off-by: Yury Norov <yury.norov@...il.com>

I'm not sure this is good to have two SoB tags for one person.

> +	if (hex_to_bin(*end) < 0)

Isn't it simple isxdigit() check?

> +		return ERR_PTR(-EINVAL);
> +

> +	for (i = 0; i < 32; i += 4) {
> +		c = hex_to_bin(*end--);
> +		if (c < 0)
> +			return ERR_PTR(-EINVAL);
> +
> +		ret |= c << i;

Dunno if it's for this series, but perhaps we would like to have something like

	/* Convert hex representation of u32 value to binary format */
	static inline int hex2bin32(const char *buf, u32 *result)
	{
		u8 value[4];
		int ret;

		ret = hex2bin(value, buf, sizeof(u32));
		if (ret)
			return ret;

		*result = get_unaligned((u32 *)value);
		// I guess it's aligned and thus can be done with:
		//   *result = be32_to_cpup((__force __be32 *)value);
		// just don't like enforcing bitwise types
		return 0;
	}

// also can be your variant with for-loop.

At least here for now and then can be moved to the kernel.h / hexdump.c.

> +
> +		if (start > end || __end_of_region(*end))
> +			goto out;
> +	}
> +

> +	if (hex_to_bin(*end) >= 0)

Isn't it simple isxdigit() check?

> +		return ERR_PTR(-EOVERFLOW);

-- 
With Best Regards,
Andy Shevchenko


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ