[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <1565455081.19079.36.camel@mhfsdcap03>
Date: Sun, 11 Aug 2019 00:38:01 +0800
From: houlong wei <houlong.wei@...iatek.com>
To: Bibby Hsieh (謝濟遠)
<Bibby.Hsieh@...iatek.com>
CC: Jassi Brar <jassisinghbrar@...il.com>,
Matthias Brugger <matthias.bgg@...il.com>,
Rob Herring <robh+dt@...nel.org>,
CK Hu (胡俊光)
<ck.hu@...iatek.com>, "Daniel Kurtz" <djkurtz@...omium.org>,
Sascha Hauer <s.hauer@...gutronix.de>,
"devicetree@...r.kernel.org" <devicetree@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"linux-arm-kernel@...ts.infradead.org"
<linux-arm-kernel@...ts.infradead.org>,
"linux-mediatek@...ts.infradead.org"
<linux-mediatek@...ts.infradead.org>,
srv_heupstream <srv_heupstream@...iatek.com>,
Sascha Hauer <kernel@...gutronix.de>,
Philipp Zabel <p.zabel@...gutronix.de>,
"Nicolas Boichat" <drinkcat@...omium.org>,
YT Shen (沈岳霆)
<Yt.Shen@...iatek.com>,
Daoyuan Huang (黃道原)
<Daoyuan.Huang@...iatek.com>,
Jiaguang Zhang (张加广)
<Jiaguang.Zhang@...iatek.com>,
Dennis-YC Hsieh (謝宇哲)
<Dennis-YC.Hsieh@...iatek.com>,
Ginny Chen (陳治傑)
<ginny.chen@...iatek.com>, <houlong.wei@...iatek.com>
Subject: Re: [PATCH v11 09/12] soc: mediatek: cmdq: define the instruction
struct
On Sun, 2019-08-11 at 00:12 +0800, houlong wei wrote:
> Hi Bibby, I have inline comment in function cmdq_pkt_write_mask().
>
> On Mon, 2019-07-29 at 15:01 +0800, Bibby Hsieh wrote:
> > Define an instruction structure for gce driver to append command.
> > This structure can make the client's code more readability.
> >
> > Signed-off-by: Bibby Hsieh <bibby.hsieh@...iatek.com>
> > Reviewed-by: CK Hu <ck.hu@...iatek.com>
> > ---
> > drivers/soc/mediatek/mtk-cmdq-helper.c | 103 +++++++++++++++--------
> > include/linux/mailbox/mtk-cmdq-mailbox.h | 2 +
> > 2 files changed, 72 insertions(+), 33 deletions(-)
> >
> > diff --git a/drivers/soc/mediatek/mtk-cmdq-helper.c b/drivers/soc/mediatek/mtk-cmdq-helper.c
> > index 7aa0517ff2f3..0886c4967ca4 100644
> > --- a/drivers/soc/mediatek/mtk-cmdq-helper.c
> > +++ b/drivers/soc/mediatek/mtk-cmdq-helper.c
> > @@ -9,12 +9,24 @@
> > #include <linux/mailbox_controller.h>
> > #include <linux/soc/mediatek/mtk-cmdq.h>
[...]
> >
> > int cmdq_pkt_write_mask(struct cmdq_pkt *pkt, u8 subsys,
> > u16 offset, u32 value, u32 mask)
> > {
> > + struct cmdq_instruction *inst;
> > u32 offset_mask = offset;
> > - int err = 0;
> >
> > if (mask != 0xffffffff) {
> > - err = cmdq_pkt_append_command(pkt, CMDQ_CODE_MASK, 0, ~mask);
> > + inst = cmdq_pkt_append_command(pkt);
> > + if (!inst)
> > + return -ENOMEM;
> > +
> > + inst->op = CMDQ_CODE_MASK;
> > + inst->mask = ~mask;
> > offset_mask |= CMDQ_WRITE_ENABLE_MASK;
> > }
> > - err |= cmdq_pkt_write(pkt, value, subsys, offset_mask);
> >
> > - return err;
> > + return cmdq_pkt_write(pkt, subsys, offset_mask, value);
We need add a type conversion here, (u8)offset_mask, for your new
function type. Er... it's better to remove local variable 'offset_mask'
and replace it with 'offset'.
> > }
[...]
Powered by blists - more mailing lists