lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 14 Aug 2019 10:28:10 +0200
From:   Linus Walleij <>
To:     Geert Uytterhoeven <>
Cc:     linux-m68k <>,
        kbuild test robot <>,
        Stefan Wahren <>,
        Michael Schmitz <>,
        Bartlomiej Zolnierkiewicz <>,
        "open list:DRM PANEL DRIVERS" <>,,
        "" <>
Subject: Re: [PATCH] m68k: atari: Rename shifter to shifter_st to avoid conflict

On Mon, Aug 12, 2019 at 9:30 AM Geert Uytterhoeven <> wrote:

> When test-compiling the BCM2835 pin control driver on m68k:
>     In file included from arch/m68k/include/asm/io_mm.h:32:0,
>                      from arch/m68k/include/asm/io.h:8,
>                      from include/linux/io.h:13,
>                      from include/linux/irq.h:20,
>                      from include/linux/gpio/driver.h:7,
>                      from drivers/pinctrl/bcm/pinctrl-bcm2835.c:17:
>     drivers/pinctrl/bcm/pinctrl-bcm2835.c: In function 'bcm2711_pull_config_set':
>     arch/m68k/include/asm/atarihw.h:190:22: error: expected identifier or '(' before 'volatile'
>      # define shifter ((*(volatile struct SHIFTER *)SHF_BAS))
> "shifter" is a too generic name for a global definition.
> As the corresponding definition for Atari TT is already called
> "shifter_tt", fix this by renaming the definition for Atari ST to
> "shifter_st".
> Reported-by: kbuild test robot <>
> Suggested-by: Michael Schmitz <>
> Signed-off-by: Geert Uytterhoeven <>

Finally we can use the sh pfc pin controller on our m68k Atari.

Now if I can only resolder the capacitors on my Atari TT ST
before the board self-destructs I will one day test this.

Reviewed-by: Linus Walleij <>

Linus Walleij

Powered by blists - more mailing lists