[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20190819143141.221906747@linutronix.de>
Date: Mon, 19 Aug 2019 16:31:41 +0200
From: Thomas Gleixner <tglx@...utronix.de>
To: LKML <linux-kernel@...r.kernel.org>
Cc: Oleg Nesterov <oleg@...hat.com>, Ingo Molnar <mingo@...nel.org>,
Peter Zijlstra <peterz@...radead.org>,
John Stultz <john.stultz@...aro.org>,
Frederic Weisbecker <fweisbec@...il.com>,
Anna-Maria Behnsen <anna-maria@...utronix.de>
Subject: [patch 00/44] posix-cpu-timers: Cleanup and consolidation
Folks!
While working on splitting the posix CPU timer expiry out into task
context, I took a deeper look at that code.
It contains quite some duplicated code and the abuse of struct task_cputime
along with the defines to rename the struct members just made my eyes bleed.
The following series cleans that up and consolidates and simplifies the
implementation. The resulting .text is about 15% smaller than the orignal
one.
It's split into small patches to make the review easier as this code is a
true can of worms and the larger patches I had initially were just an
invitation to overlook subtle issues.
The series applies on top of:
git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git timers/core
and is available from git as well:
git://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git WIP.timers/core
Thanks,
tglx
8<--------------
include/linux/alarmtimer.h | 3
include/linux/init_task.h | 11
include/linux/posix-timers.h | 112 +++-
include/linux/sched.h | 26 -
include/linux/sched/cputime.h | 12
include/linux/sched/signal.h | 13
include/linux/sched/types.h | 21
include/linux/timerqueue.h | 10
init/init_task.c | 2
kernel/fork.c | 34 -
kernel/sched/rt.c | 6
kernel/time/alarmtimer.c | 14
kernel/time/itimer.c | 11
kernel/time/posix-cpu-timers.c | 1033 ++++++++++++++++++-----------------------
kernel/time/posix-timers.c | 32 -
kernel/time/posix-timers.h | 1
kernel/time/timer.c | 2
17 files changed, 659 insertions(+), 684 deletions(-)
Powered by blists - more mailing lists