[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20190910091619.GA207290@jagdpanzerIV>
Date: Tue, 10 Sep 2019 18:16:19 +0900
From: Sergey Senozhatsky <sergey.senozhatsky.work@...il.com>
To: Kees Cook <keescook@...omium.org>
Cc: Sergey Senozhatsky <sergey.senozhatsky@...il.com>,
Andrew Morton <akpm@...ux-foundation.org>,
Christophe Leroy <christophe.leroy@....fr>,
Peter Zijlstra <peterz@...radead.org>,
Drew Davenport <ddavenport@...omium.org>,
Arnd Bergmann <arnd@...db.de>,
"Steven Rostedt (VMware)" <rostedt@...dmis.org>,
Feng Tang <feng.tang@...el.com>,
Petr Mladek <pmladek@...e.com>,
Mauro Carvalho Chehab <mchehab+samsung@...nel.org>,
Borislav Petkov <bp@...e.de>,
YueHaibing <yuehaibing@...wei.com>, linux-arch@...r.kernel.org,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v2 7/7] bug: Move WARN_ON() "cut here" into exception
handler
On (09/10/19 01:59), Kees Cook wrote:
> On Tue, Sep 10, 2019 at 01:05:39AM +0900, Sergey Senozhatsky wrote:
> > On (08/20/19 09:47), Kees Cook wrote:
> > [..]
> > > + /*
> > > + * BUG() and WARN_ON() families don't print a custom debug message
> > > + * before triggering the exception handler, so we must add the
> > > + * "cut here" line now. WARN() issues its own "cut here" before the
> > > + * extra debugging message it writes before triggering the handler.
> > > + */
> > > + if ((bug->flags & BUGFLAG_NO_CUT_HERE) == 0)
> > > + printk(KERN_DEFAULT CUT_HERE);
> >
> > Shouldn't this be pr_warn() or pr_crit()?
>
> The pr_* helpers here would (potentially) add unwanted prefixes, so
> those aren't used. KERN_DEFAULT is used here because that's how it's
> always been printed. I didn't want to change that for this refactoring
> work. I'm not opposed to it, generally speaking, though. :)
I just glanced through CUT_HERE users
warn_slowpath_fmt() pr_warn(CUT_HERE)
__warn_printk() pr_warn(CUT_HERE)
rdma_restrack_clean() pr_err("restrack: %s", CUT_HERE)
rdma_restrack_clean() pr_err("restrack: %s", CUT_HERE)
+ oops/panic end markers are of pr_warn() or pr_crit() log levels.
So I thought that maybe we can make it more or less similar.
But if it has always been this way (KERN_DEFAULT) then OK.
-ss
Powered by blists - more mailing lists