[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <201909240920.AE3CD67E87@keescook>
Date: Tue, 24 Sep 2019 09:22:10 -0700
From: Kees Cook <keescook@...omium.org>
To: Pankaj Bharadiya <pankaj.laxminarayan.bharadiya@...el.com>
Cc: pankaj.bharadiya@...il.com, andriy.shevchenko@...ux.intel.com,
kernel-hardening@...ts.openwall.com, akpm@...ux-foundation.org,
mayhs11saini@...il.com, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/5] linux/kernel.h: Add sizeof_member macro
On Tue, Sep 24, 2019 at 04:28:35PM +0530, Pankaj Bharadiya wrote:
> At present we have 3 different macros to calculate the size of a
> member of a struct:
> - SIZEOF_FIELD
> - FIELD_SIZEOF
> - sizeof_field
>
> To bring uniformity in entire kernel source tree let's add
> sizeof_member macro.
>
> Replace all occurrences of above 3 macro's with sizeof_member in
> future patches.
>
> Signed-off-by: Pankaj Bharadiya <pankaj.laxminarayan.bharadiya@...el.com>
> ---
> include/linux/kernel.h | 9 +++++++++
> 1 file changed, 9 insertions(+)
Since stddef.h ends up needing this macro, and kernel.h includes
stddef.h, why not put this macro in stddef.h instead? Then the
open-coded version of it in stddef (your last patch) can use
sizeof_member()?
Otherwise, yes, looks good. (Though I might re-order the patches so the
last patch is the tree-wide swap -- then you don't need the exclusions,
I think?)
-Kees
>
> diff --git a/include/linux/kernel.h b/include/linux/kernel.h
> index 4fa360a13c1e..0b80d8bb3978 100644
> --- a/include/linux/kernel.h
> +++ b/include/linux/kernel.h
> @@ -79,6 +79,15 @@
> */
> #define round_down(x, y) ((x) & ~__round_mask(x, y))
>
> +/**
> + * sizeof_member - get the size of a struct's member
> + * @T: the target struct
> + * @m: the target struct's member
> + * Return: the size of @m in the struct definition without having a
> + * declared instance of @T.
> + */
> +#define sizeof_member(T, m) (sizeof(((T *)0)->m))
> +
> /**
> * FIELD_SIZEOF - get the size of a struct's field
> * @t: the target struct
> --
> 2.17.1
>
--
Kees Cook
Powered by blists - more mailing lists