[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <8c54adaf-163f-fcbe-7731-0c18b12410e0@huawei.com>
Date: Sun, 29 Sep 2019 08:53:05 +0800
From: Chao Yu <yuchao0@...wei.com>
To: Jaegeuk Kim <jaegeuk@...nel.org>
CC: <linux-f2fs-devel@...ts.sourceforge.net>,
<linux-kernel@...r.kernel.org>, <chao@...nel.org>
Subject: Re: [PATCH] f2fs: fix comment of f2fs_evict_inode
Hi Jaegeuk,
On 2019/9/28 2:31, Jaegeuk Kim wrote:
> Hi Chao,
>
> On 09/25, Chao Yu wrote:
>> evict() should be called once i_count is zero, rather than i_nlinke
>> is zero.
>>
>> Reported-by: Gao Xiang <gaoxiang25@...wei.com>
>> Signed-off-by: Chao Yu <yuchao0@...wei.com>
>> ---
>> fs/f2fs/inode.c | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/fs/f2fs/inode.c b/fs/f2fs/inode.c
>> index db4fec30c30d..8262f4a483d3 100644
>> --- a/fs/f2fs/inode.c
>> +++ b/fs/f2fs/inode.c
>> @@ -632,7 +632,7 @@ int f2fs_write_inode(struct inode *inode, struct writeback_control *wbc)
>> }
>>
>> /*
>> - * Called at the last iput() if i_nlink is zero
>
> I don't think this comment is wrong. You may be able to add on top of this.
It actually misleads the developer or user.
How do you think of:
"Called at the last iput() if i_count is zero, and will release all meta/data
blocks allocated in the inode if i_nlink is zero"
Thanks,
>
>> + * Called at the last iput() if i_count is zero
>> */
>> void f2fs_evict_inode(struct inode *inode)
>> {
>> --
>> 2.18.0.rc1
> .
>
Powered by blists - more mailing lists