[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20191001111552.GA18622@gofer.mess.org>
Date: Tue, 1 Oct 2019 12:15:53 +0100
From: Sean Young <sean@...s.org>
To: zhong jiang <zhongjiang@...wei.com>
Cc: mchehab@...nel.org, hansverk@...co.com, daniel.vetter@...ll.ch,
linux-media@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH 1/4] media: dvb-frontends: Use DIV_ROUND_CLOSEST directly
to make it readable
Hi,
On Fri, Sep 06, 2019 at 12:14:49AM +0800, zhong jiang wrote:
> The kernel.h macro DIV_ROUND_CLOSEST performs the computation (x + d/2)/d
> but is perhaps more readable.
>
> Signed-off-by: zhong jiang <zhongjiang@...wei.com>
> ---
> drivers/media/dvb-frontends/mt312.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/media/dvb-frontends/mt312.c b/drivers/media/dvb-frontends/mt312.c
> index 7cae7d6..251ff41 100644
> --- a/drivers/media/dvb-frontends/mt312.c
> +++ b/drivers/media/dvb-frontends/mt312.c
> @@ -137,7 +137,7 @@ static inline int mt312_writereg(struct mt312_state *state,
>
> static inline u32 mt312_div(u32 a, u32 b)
> {
> - return (a + (b / 2)) / b;
> + return DIV_ROUND_CLOSEST(a, b);
Well spotted, that is absolutely correct. However now mt312_div() is just
a wrapper for DIV_ROUND_CLOSEST() -- and even marked inline. Really all
the callers to mt312_div() should be replaced with DIV_ROUND_CLOSEST().
Thanks,
Sean
Powered by blists - more mailing lists