lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <20191002204803.jb2q6cufudau6txf@treble>
Date:   Wed, 2 Oct 2019 15:48:03 -0500
From:   Josh Poimboeuf <jpoimboe@...hat.com>
To:     Peter Zijlstra <peterz@...radead.org>
Cc:     Nadav Amit <namit@...are.com>,
        the arch/x86 maintainers <x86@...nel.org>,
        LKML <linux-kernel@...r.kernel.org>,
        Ard Biesheuvel <ard.biesheuvel@...aro.org>,
        Andy Lutomirski <luto@...nel.org>,
        Steven Rostedt <rostedt@...dmis.org>,
        Ingo Molnar <mingo@...nel.org>,
        Thomas Gleixner <tglx@...utronix.de>,
        Linus Torvalds <torvalds@...ux-foundation.org>,
        Masami Hiramatsu <mhiramat@...nel.org>,
        Jason Baron <jbaron@...mai.com>, Jiri Kosina <jkosina@...e.cz>,
        David Laight <David.Laight@...LAB.COM>,
        Borislav Petkov <bp@...en8.de>,
        Julia Cartwright <julia@...com>, Jessica Yu <jeyu@...nel.org>,
        "H. Peter Anvin" <hpa@...or.com>,
        Rasmus Villemoes <linux@...musvillemoes.dk>,
        Edward Cree <ecree@...arflare.com>,
        Daniel Bristot de Oliveira <bristot@...hat.com>
Subject: Re: [PATCH 10/15] static_call: Add basic static call infrastructure

On Wed, Oct 02, 2019 at 03:54:17PM +0200, Peter Zijlstra wrote:
> On Fri, Jun 07, 2019 at 10:28:51AM +0200, Peter Zijlstra wrote:
> > On Thu, Jun 06, 2019 at 10:44:23PM +0000, Nadav Amit wrote:
> > > > + * Usage example:
> > > > + *
> > > > + *   # Start with the following functions (with identical prototypes):
> > > > + *   int func_a(int arg1, int arg2);
> > > > + *   int func_b(int arg1, int arg2);
> > > > + *
> > > > + *   # Define a 'my_key' reference, associated with func_a() by default
> > > > + *   DEFINE_STATIC_CALL(my_key, func_a);
> > > > + *
> > > > + *   # Call func_a()
> > > > + *   static_call(my_key, arg1, arg2);
> > > > + *
> > > > + *   # Update 'my_key' to point to func_b()
> > > > + *   static_call_update(my_key, func_b);
> > > > + *
> > > > + *   # Call func_b()
> > > > + *   static_call(my_key, arg1, arg2);
> > > 
> > > I think that this calling interface is not very intuitive.
> > 
> > Yeah, it is somewhat unfortunate..
> > 
> > > I understand that
> > > the macros/objtool cannot allow the calling interface to be completely
> > > transparent (as compiler plugin could). But, can the macros be used to
> > > paste the key with the “static_call”? I think that having something like:
> > > 
> > >   static_call__func(arg1, arg2)
> > > 
> > > Is more readable than
> > > 
> > >   static_call(func, arg1, arg2)
> > 
> > Doesn't really make it much better for me; I think I'd prefer to switch
> > to the GCC plugin scheme over this.  ISTR there being some propotypes
> > there, but I couldn't quickly locate them.
> 
> How about something like:
> 
> 	static_call(key)(arg1, arg2);
> 
> which is very close to the regular indirect call syntax.

Looks ok to me.

> Furthermore, how about we put the trampolines in .static_call.text
> instead of relying on prefixes?

Yeah, that would probably be better.

> Also, I think I can shrink static_call_key by half:
> 
>  - we can do away with static_call_key::tramp; there are only two usage
>    sites:
> 
>      o __static_call_update, the static_call() macro can provide the
>        address of STATIC_CALL_TRAMP(key) directly
> 
>      o static_call_add_module(), has two cases:
> 
>        * the trampoline is from outside the module; in this case
>          it will already have been updated by a previous call to
> 	 __static_call_update.
>        * the trampoline is from inside the module; in this case
>          it will have the default value and it doesn't need an
> 	 update.
> 
>        so in no case does static_call_add_module() need to modify a
>        trampoline.

Sounds plausible.

>   - we can change static_call_key::site_mods into a single next pointer,
>     just like jump_label's static_key.

Yep.

> But so far all the schemes I've come up with require 'key' to be a name,
> it cannot be an actual 'struct static_call_key *' value. And therefore
> usage from within structures isn't allowed.

Is that something we need?  At least we were able to work around this
limitation with tracepoints' usage of static calls.  But I could see how
it could be useful.

One way to solve that would be a completely different implementation:
have a global trampoline which detects the call site of the caller,
associates it with the given key, schedules some work to patch the call
site later, and then jumps to key->func.  So the first call would
trigger the patching.

Then we might not even need objtool :-)  But it might be tricky to pull
off.

-- 
Josh

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ