[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <8497734.zbLCBLinYR@kreacher>
Date: Fri, 11 Oct 2019 11:20:15 +0200
From: "Rafael J. Wysocki" <rjw@...ysocki.net>
To: Dmitry Torokhov <dmitry.torokhov@...il.com>
Cc: "Rafael J. Wysocki" <rafael@...nel.org>,
Heikki Krogerus <heikki.krogerus@...ux.intel.com>,
Andy Shevchenko <andriy.shevchenko@...ux.intel.com>,
Linus Walleij <linus.walleij@...aro.org>,
linux-kernel@...r.kernel.org, platform-driver-x86@...r.kernel.org
Subject: Re: [PATCH v3 00/13] software node: add support for reference properties
On Monday, September 9, 2019 10:15:44 AM CEST Dmitry Torokhov wrote:
> These series implement "references" properties for software nodes as true
> properties, instead of managing them completely separately.
>
> The first 10 patches are generic cleanups and consolidation and unification
> of the existing code; patch #11 implements PROPERTY_EMTRY_REF() and friends;
> patch #12 converts the user of references to the property syntax, and patch
> #13 removes the remains of references as entities that are managed
> separately.
>
> Changes in v3:
> - added various cleanups before implementing reference properties
>
> Changes in v2:
> - reworked code so that even single-entry reference properties are
> stored as arrays (i.e. the software_node_ref_args instances are
> not part of property_entry structure) to avoid size increase.
> From user's POV nothing is changed, one can still use PROPERTY_ENTRY_REF
> macro to define reference "inline".
> - dropped unused DEV_PROP_MAX
> - rebased on linux-next
>
> Dmitry Torokhov (13):
> software node: remove DEV_PROP_MAX
> software node: clean up property_copy_string_array()
> software node: get rid of property_set_pointer()
> software node: simplify property_get_pointer()
> software node: remove property_entry_read_uNN_array functions
> software node: unify PROPERTY_ENTRY_XXX macros
> software node: simplify property_entry_read_string_array()
> software node: introduce PROPERTY_ENTRY_ARRAY_XXX_LEN()
> efi/apple-properties: use PROPERTY_ENTRY_U8_ARRAY_LEN
> software node: rename is_array to is_inline
> software node: implement reference properties
> platform/x86: intel_cht_int33fe: use inline reference properties
> software node: remove separate handling of references
>
> drivers/base/swnode.c | 243 +++++++----------------
> drivers/firmware/efi/apple-properties.c | 8 +-
> drivers/platform/x86/intel_cht_int33fe.c | 81 ++++----
> include/linux/property.h | 154 +++++++-------
> 4 files changed, 198 insertions(+), 288 deletions(-)
I think that this is still relevant, so can you please resend it with a CC
to linux-acpi@...r.kernel.org? It would be much easier to handle for me then.
Powered by blists - more mailing lists