[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20191015182206.GF105649@dtor-ws>
Date: Tue, 15 Oct 2019 11:22:06 -0700
From: Dmitry Torokhov <dmitry.torokhov@...il.com>
To: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
Cc: "Rafael J. Wysocki" <rafael@...nel.org>,
Heikki Krogerus <heikki.krogerus@...ux.intel.com>,
Mika Westerberg <mika.westerberg@...ux.intel.com>,
Linus Walleij <linus.walleij@...aro.org>,
Ard Biesheuvel <ard.biesheuvel@...aro.org>,
linux-acpi@...r.kernel.org, linux-kernel@...r.kernel.org,
platform-driver-x86@...r.kernel.org
Subject: Re: [PATCH v5 10/14] software node: rename is_array to is_inline
On Mon, Oct 14, 2019 at 10:37:20AM +0300, Andy Shevchenko wrote:
> On Fri, Oct 11, 2019 at 04:07:17PM -0700, Dmitry Torokhov wrote:
> > We do not need a special flag to know if we are dealing with an array,
> > as we can get that data from ratio between element length and the data
> > size, however we do need a flag to know whether the data is stored
> > directly inside property_entry or separately.
>
> > - if (prop->is_array)
> > + if (!prop->is_inline)
>
> > - if (p->is_array) {
> > + if (!p->is_inline) {
>
> > - if (src->is_array) {
> > + if (!src->is_inline) {
>
> May we have positive conditionals instead?
I was trying to limit the context churn. I can definitely change
property_get_pointer(), but the other 2 I think are better in the
current form.
>
> > + * @is_inline: True when the property value is stored directly in
>
> I think word 'directly' is superfluous here.
> Or, perhaps, 'stored directly' -> 'embedded'
I'm OK with "embedded".
>
> > + * &struct property_entry instance.
>
> > + * @pointer: Pointer to the property when it is stored separately from
> > + * the &struct property_entry instance.
>
> 'separately from' -> 'outside' ?
Umm, I think I prefer "separately" actually.
>
> > + * @value: Value of the property when it is stored inline.
>
> 'stored inline' -> 'embedded in the &struct...' ?
I was trying to have a link "stored inline" -> "is_inline".
Do we want to change the flag to be "is_embedded"?
Thanks.
--
Dmitry
Powered by blists - more mailing lists