[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20191016162408.GB31585@redhat.com>
Date: Wed, 16 Oct 2019 18:24:09 +0200
From: Oleg Nesterov <oleg@...hat.com>
To: Christian Brauner <christian.brauner@...ntu.com>
Cc: linux-kernel@...r.kernel.org, aarcange@...hat.com,
akpm@...ux-foundation.org, christian@...lner.me, cyphar@...har.com,
elena.reshetova@...el.com, guro@...com, jannh@...gle.com,
ldv@...linux.org, linux-api@...r.kernel.org,
linux-kselftest@...r.kernel.org, mhocko@...e.com, mingo@...nel.org,
peterz@...radead.org, shuah@...nel.org, tglx@...utronix.de,
viro@...iv.linux.org.uk
Subject: Re: [PATCH v2 1/5] pidfd: verify task is alive when printing fdinfo
On 10/16, Christian Brauner wrote:
>
> +static inline bool task_alive(struct pid *pid, enum pid_type type)
> +{
> + return !hlist_empty(&pid->tasks[type]);
> +}
So you decided to add a helper ;) OK, but note that its name is very
confusing and misleading. Even more than pid_alive() we already have.
What does "alive" actually mean? Say, task_alive(pid, PIDTYPE_SID) == F
after fork(). Then it becomes T if this task does setsid().
And why task_ if it accepts pid+pid_type? May be pid_has_task() or
something like this...
OK, since I can't suggest a better name I won't really argue. Feel free
to add my reviewed-by to this series.
Oleg.
Powered by blists - more mailing lists