lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20191022172922.61232-1-andriy.shevchenko@linux.intel.com>
Date:   Tue, 22 Oct 2019 20:29:11 +0300
From:   Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
To:     Linus Walleij <linus.walleij@...aro.org>,
        Bartosz Golaszewski <bgolaszewski@...libre.com>,
        linux-gpio@...r.kernel.org,
        Rasmus Villemoes <linux@...musvillemoes.dk>,
        Yury Norov <yury.norov@...il.com>,
        linux-kernel@...r.kernel.org,
        Andrew Morton <akpm@...ux-foundation.org>,
        William Breathitt Gray <vilhelm.gray@...il.com>
Cc:     Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
Subject: [PATCH v2 00/11] gpio: pca953x: Convert to bitmap (extended) API

While converting gpio-pca953x driver to bitmap API, I noticed that we have
no function to replace bits.

So, that's how patch 7 appears.

First 6 patches are preparatory of the test suite (including some warning
fixes, etc).

Patches 8-9 are preparatory for the GPIO driver to be easier converted
to bitmap API, conversion to which happens in patch 10.

Patch 11 simple indentation fixes.

Since the series depends to the commit e51819d749db ("bitops: introduce the
for_each_set_clump8 macro") in Andrew's set and taking into consideration
a lot of bitmap related patches here, it would make sense to route these thru
Andrew as well.

In v2:
- address wrong logic in pca953x_gpio_set_multiple() (William)
- 10 more patches as described above

Andy Shevchenko (11):
  lib/test_bitmap: Force argument of bitmap_parselist_user() to proper
    address space
  lib/test_bitmap: Undefine macros after use
  lib/test_bitmap: Name EXP_BYTES properly
  lib/test_bitmap: Rename exp to exp1 to avoid ambiguous name
  lib/test_bitmap: Move exp1 and exp2 upper for others to use
  lib/test_bitmap: Fix comment about this file
  bitmap: Introduce bitmap_replace() helper
  gpio: pca953x: Remove redundant variable and check in IRQ handler
  gpio: pca953x: Use input from regs structure in pca953x_irq_pending()
  gpio: pca953x: Convert to use bitmap API
  gpio: pca953x: Tight up indentation

 drivers/gpio/gpio-pca953x.c | 196 ++++++++++++++++--------------------
 include/linux/bitmap.h      |  16 +++
 lib/bitmap.c                |  12 +++
 lib/test_bitmap.c           | 137 ++++++++++++++++---------
 4 files changed, 203 insertions(+), 158 deletions(-)

-- 
2.23.0

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ