[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20191028154503.GB15449@krava>
Date: Mon, 28 Oct 2019 16:45:03 +0100
From: Jiri Olsa <jolsa@...hat.com>
To: Adrian Hunter <adrian.hunter@...el.com>
Cc: Peter Zijlstra <peterz@...radead.org>,
Ingo Molnar <mingo@...hat.com>, Borislav Petkov <bp@...en8.de>,
"H . Peter Anvin" <hpa@...or.com>, x86@...nel.org,
Mark Rutland <mark.rutland@....com>,
Alexander Shishkin <alexander.shishkin@...ux.intel.com>,
Mathieu Poirier <mathieu.poirier@...aro.org>,
Leo Yan <leo.yan@...aro.org>,
Arnaldo Carvalho de Melo <acme@...nel.org>,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH RFC 3/6] perf dso: Add dso__data_write_cache_addr()
On Fri, Oct 25, 2019 at 03:59:57PM +0300, Adrian Hunter wrote:
SNIP
>
> -static ssize_t data_read_offset(struct dso *dso, struct machine *machine,
> - u64 offset, u8 *data, ssize_t size)
> +static ssize_t data_read_write_offset(struct dso *dso, struct machine *machine,
> + u64 offset, u8 *data, ssize_t size,
> + bool out)
> {
> if (dso__data_file_size(dso, machine))
> return -1;
> @@ -1034,7 +1037,7 @@ static ssize_t data_read_offset(struct dso *dso, struct machine *machine,
> if (offset + size < offset)
> return -1;
>
> - return cached_read(dso, machine, offset, data, size);
> + return cached_io(dso, machine, offset, data, size, out);
you renamed the function as _read_write_ so the bool choosing
the opration should be named either read or write.. I had to
go all the way down to find out what 'out' means ;-)
jirka
Powered by blists - more mailing lists