[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <7bc9d610-728c-37b0-d175-dba21dc0dfff@huawei.com>
Date: Tue, 5 Nov 2019 16:21:44 +0800
From: Yunfeng Ye <yeyunfeng@...wei.com>
To: <n-horiguchi@...jp.nec.com>
CC: <linux-mm@...ck.org>, <linux-kernel@...r.kernel.org>,
"hushiyuan@...wei.com" <hushiyuan@...wei.com>,
"linfeilong@...wei.com" <linfeilong@...wei.com>
Subject: [PATCH] mm/memory-failure.c: replace with page_shift() in
add_to_kill()
The function page_shift() is supported after the commit 94ad9338109f
("mm: introduce page_shift()").
So replace with page_shift() in add_to_kill() for readability.
Signed-off-by: Yunfeng Ye <yeyunfeng@...wei.com>
---
mm/memory-failure.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/mm/memory-failure.c b/mm/memory-failure.c
index 3151c87dff73..e48c50cac889 100644
--- a/mm/memory-failure.c
+++ b/mm/memory-failure.c
@@ -326,7 +326,7 @@ static void add_to_kill(struct task_struct *tsk, struct page *p,
if (is_zone_device_page(p))
tk->size_shift = dev_pagemap_mapping_shift(p, vma);
else
- tk->size_shift = compound_order(compound_head(p)) + PAGE_SHIFT;
+ tk->size_shift = page_shift(compound_head(p));
/*
* Send SIGKILL if "tk->addr == -EFAULT". Also, as
--
2.7.4
Powered by blists - more mailing lists