[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <0220b5ff-bc47-9616-3897-52fa1c674487@huawei.com>
Date: Tue, 5 Nov 2019 18:18:49 +0800
From: Yunfeng Ye <yeyunfeng@...wei.com>
To: David Hildenbrand <david@...hat.com>, <n-horiguchi@...jp.nec.com>
CC: <linux-mm@...ck.org>, <linux-kernel@...r.kernel.org>,
"hushiyuan@...wei.com" <hushiyuan@...wei.com>,
"linfeilong@...wei.com" <linfeilong@...wei.com>
Subject: Re: [PATCH v2] mm/memory-failure.c: replace with page_shift() in
add_to_kill()
On 2019/11/5 17:50, David Hildenbrand wrote:
> On 05.11.19 10:38, Yunfeng Ye wrote:
>> The function page_shift() is supported after the commit 94ad9338109f
>> ("mm: introduce page_shift()").
>>
>> So replace with page_shift() in add_to_kill() for readability.
>>
>> Signed-off-by: Yunfeng Ye <yeyunfeng@...wei.com>
>> Reviewed-by: David Hildenbrand <david@...hat.com>
>> Acked-by: Naoya Horiguchi <n-horiguchi@...jp.nec.com>
>> ---
>> v1 -> v2:
>> - add Reviewed-by and Acked-by
>
> Note for the future: No need to resend if there were no code/documentation changes. Andrew will apply the tags when picking up the patch.
>
ok, thanks.
>>
>> mm/memory-failure.c | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/mm/memory-failure.c b/mm/memory-failure.c
>> index 3151c87dff73..e48c50cac889 100644
>> --- a/mm/memory-failure.c
>> +++ b/mm/memory-failure.c
>> @@ -326,7 +326,7 @@ static void add_to_kill(struct task_struct *tsk, struct page *p,
>> if (is_zone_device_page(p))
>> tk->size_shift = dev_pagemap_mapping_shift(p, vma);
>> else
>> - tk->size_shift = compound_order(compound_head(p)) + PAGE_SHIFT;
>> + tk->size_shift = page_shift(compound_head(p));
>>
>> /*
>> * Send SIGKILL if "tk->addr == -EFAULT". Also, as
>>
>
>
Powered by blists - more mailing lists