lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date:   Tue, 5 Nov 2019 12:25:18 +0100
From:   Jan Kara <jack@...e.cz>
To:     Nikitas Angelinas <nikitas.angelinas@...il.com>
Cc:     Andrew Morton <akpm@...ux-foundation.org>, zhengbin@...tro.suse.de,
        zhengbin13@...wei.com, Jan Kara <jack@...e.cz>,
        Al Viro <viro@...iv.linux.org.uk>,
        reiserfs-devel@...r.kernel.org, linux-kernel@...r.kernel.org
Subject: Re: [PATCH] reiserfs: replace open-coded atomic_dec_and_mutex_lock()

On Sun 03-11-19 01:44:54, Nikitas Angelinas wrote:
> Replace the open-coded logic of atomic_dec_and_mutex_lock() in
> reiserfs_file_release().
> 
> Signed-off-by: Nikitas Angelinas <nikitas.angelinas@...il.com>

Thanks! The patch looks good to me. I've added it to my tree.

								Honza

> ---
>  fs/reiserfs/file.c | 10 ++--------
>  1 file changed, 2 insertions(+), 8 deletions(-)
> 
> diff --git a/fs/reiserfs/file.c b/fs/reiserfs/file.c
> index 843aadc..84cf8bd 100644
> --- a/fs/reiserfs/file.c
> +++ b/fs/reiserfs/file.c
> @@ -38,16 +38,10 @@ static int reiserfs_file_release(struct inode *inode, struct file *filp)
>  
>  	BUG_ON(!S_ISREG(inode->i_mode));
>  
> -        if (atomic_add_unless(&REISERFS_I(inode)->openers, -1, 1))
> +	if (!atomic_dec_and_mutex_lock(&REISERFS_I(inode)->openers,
> +				       &REISERFS_I(inode)->tailpack))
>  		return 0;
>  
> -	mutex_lock(&REISERFS_I(inode)->tailpack);
> -
> -        if (!atomic_dec_and_test(&REISERFS_I(inode)->openers)) {
> -		mutex_unlock(&REISERFS_I(inode)->tailpack);
> -		return 0;
> -	}
> -
>  	/* fast out for when nothing needs to be done */
>  	if ((!(REISERFS_I(inode)->i_flags & i_pack_on_close_mask) ||
>  	     !tail_has_to_be_packed(inode)) &&
> -- 
> 2.10.0
> 
-- 
Jan Kara <jack@...e.com>
SUSE Labs, CR

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ