[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <29dce60c-38d6-0220-f292-e298f0c78c4d@huawei.com>
Date: Wed, 6 Nov 2019 15:06:27 +0800
From: Yunfeng Ye <yeyunfeng@...wei.com>
To: <akpm@...ux-foundation.org>, <jgg@...pe.ca>, <mhocko@...e.com>,
<jglisse@...hat.com>, <minchan@...nel.org>, <peterz@...radead.org>,
<jack@...e.cz>, <rppt@...ux.ibm.com>
CC: <linux-mm@...ck.org>, <linux-kernel@...r.kernel.org>,
"hushiyuan@...wei.com" <hushiyuan@...wei.com>,
"linfeilong@...wei.com" <linfeilong@...wei.com>
Subject: [PATCH] mm/madvise: replace with page_size() in
madvise_inject_error()
The function page_size() is supported after the commit a50b854e073c
("mm: introduce page_size()").
Replace with page_size() in madvise_inject_error() for readability.
Signed-off-by: Yunfeng Ye <yeyunfeng@...wei.com>
---
mm/madvise.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/mm/madvise.c b/mm/madvise.c
index 2be9f3fdb05e..38c4e7fcf850 100644
--- a/mm/madvise.c
+++ b/mm/madvise.c
@@ -856,13 +856,13 @@ static int madvise_inject_error(int behavior,
{
struct page *page;
struct zone *zone;
- unsigned int order;
+ unsigned int size;
if (!capable(CAP_SYS_ADMIN))
return -EPERM;
- for (; start < end; start += PAGE_SIZE << order) {
+ for (; start < end; start += size) {
unsigned long pfn;
int ret;
@@ -874,9 +874,9 @@ static int madvise_inject_error(int behavior,
/*
* When soft offlining hugepages, after migrating the page
* we dissolve it, therefore in the second loop "page" will
- * no longer be a compound page, and order will be 0.
+ * no longer be a compound page.
*/
- order = compound_order(compound_head(page));
+ size = page_size(compound_head(page));
if (PageHWPoison(page)) {
put_page(page);
--
2.7.4
Powered by blists - more mailing lists