lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 7 Nov 2019 22:43:41 +0900
From:   Masami Hiramatsu <mhiramat@...nel.org>
To:     Arnaldo Carvalho de Melo <acme@...nel.org>
Cc:     Ingo Molnar <mingo@...hat.com>,
        Steven Rostedt <rostedt@...dmis.org>,
        linux-kernel@...r.kernel.org,
        Tom Zanussi <tom.zanussi@...ux.intel.com>,
        Ravi Bangoria <ravi.bangoria@...ux.ibm.com>,
        Namhyung Kim <namhyung@...nel.org>
Subject: Re: [PATCH 2/5] perf probe: Generate event name with line number

Hi Arnaldo,

On Wed, 6 Nov 2019 16:54:32 -0300
Arnaldo Carvalho de Melo <acme@...nel.org> wrote:

> Em Tue, Nov 05, 2019 at 09:16:59AM +0900, Masami Hiramatsu escreveu:
> > Generate event name from function name with line number
> > as <function>_L<line_number>. Note that this is only for
> > the new event which is defined by function and lines.
> > 
> > If there is another event on same line, you have to use
> > "-f" option. In that case, the new event has "_1" suffix.
> 
> So I don't like this, the existing practice of, if given a function
> name, just create the probe:name looks more natural, if one states
> kernel:1, then, sure, appending L1 to them is natural, better than the
> previous naming convention,

OK, then what about adding L* only when the user add it on a
specific line (like kernel_read:1) ?
IOW, _L0 will be skipped.

Thank you,

> 
> Thanks,
> 
> - Arnaldo
>  
> >  e.g.
> >   # perf probe -a kernel_read
> >   Added new event:
> >     probe:kernel_read_L0 (on kernel_read)
> > 
> >   You can now use it in all perf tools, such as:
> > 
> >   	perf record -e probe:kernel_read_L0 -aR sleep 1
> > 
> >   # perf probe -a kernel_read:1
> >   Added new events:
> >     probe:kernel_read_L1 (on kernel_read:1)
> > 
> >   You can now use it in all perf tools, such as:
> > 
> >   	perf record -e probe:kernel_read_L1_1 -aR sleep 1
> > 
> >   # perf probe -l
> >     probe:kernel_read_L0 (on kernel_read@...ux/linux/fs/read_write.c)
> >     probe:kernel_read_L1 (on kernel_read@...ux/linux/fs/read_write.c)
> > 
> > Signed-off-by: Masami Hiramatsu <mhiramat@...nel.org>
> > ---
> >  tools/perf/util/probe-event.c |    8 ++++++++
> >  1 file changed, 8 insertions(+)
> > 
> > diff --git a/tools/perf/util/probe-event.c b/tools/perf/util/probe-event.c
> > index 91cab5f669d2..d14b970a6461 100644
> > --- a/tools/perf/util/probe-event.c
> > +++ b/tools/perf/util/probe-event.c
> > @@ -1679,6 +1679,14 @@ int parse_perf_probe_command(const char *cmd, struct perf_probe_event *pev)
> >  	if (ret < 0)
> >  		goto out;
> >  
> > +	/* Generate event name if needed */
> > +	if (!pev->event && pev->point.function
> > +			&& !pev->point.lazy_line && !pev->point.offset) {
> > +		if (asprintf(&pev->event, "%s_L%d", pev->point.function,
> > +			pev->point.line) < 0)
> > +			return -ENOMEM;
> > +	}
> > +
> >  	/* Copy arguments and ensure return probe has no C argument */
> >  	pev->nargs = argc - 1;
> >  	pev->args = zalloc(sizeof(struct perf_probe_arg) * pev->nargs);
> 
> -- 
> 
> - Arnaldo


-- 
Masami Hiramatsu <mhiramat@...nel.org>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ