lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 13 Nov 2019 22:59:47 +0100
From:   "Rafael J. Wysocki" <rafael@...nel.org>
To:     Daniel Lezcano <daniel.lezcano@...aro.org>
Cc:     "Rafael J. Wysocki" <rafael@...nel.org>,
        Linux PM <linux-pm@...r.kernel.org>,
        Linux Kernel Mailing List <linux-kernel@...r.kernel.org>,
        Ulf Hansson <ulf.hansson@...aro.org>
Subject: Re: [PATCH RFC 1/3] cpuidle: Replace use_deepest_state flag by use_latency

On Wed, Nov 13, 2019 at 7:54 PM Daniel Lezcano
<daniel.lezcano@...aro.org> wrote:
>
> We want to specify a latency constraint when choosing an idle state at
> play_idle time. Instead of duplicating the information in the
> structure or propagate the latency in the call stack, change the
> use_deepest_state by use_latency to introduce this constraint.
>
> A zero latency constraint means "do not use the deepest idle state
> path" as the 'use_deepest_state' boolean was used in the
> cpuidle_idle_call.
>
> Signed-off-by: Daniel Lezcano <daniel.lezcano@...aro.org>
> ---
>  drivers/cpuidle/cpuidle.c | 6 +++---
>  include/linux/cpuidle.h   | 6 +++---
>  kernel/sched/idle.c       | 6 +++---
>  3 files changed, 9 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/cpuidle/cpuidle.c b/drivers/cpuidle/cpuidle.c
> index 44ae39f2b47a..f68a6c9e8482 100644
> --- a/drivers/cpuidle/cpuidle.c
> +++ b/drivers/cpuidle/cpuidle.c
> @@ -100,19 +100,19 @@ static int find_deepest_state(struct cpuidle_driver *drv,
>
>  /**
>   * cpuidle_use_deepest_state - Set/clear governor override flag.
> - * @enable: New value of the flag.
> + * @latency: A latency constraint

I would call this latency_limit.

Maybe even latency_limit_ns (or us, whatever is more suitable), to
make it clear which unit of time is used here.

>   *
>   * Set/unset the current CPU to use the deepest idle state (override governors
>   * going forward if set).

I would update the comment too, something like:

"Set/unset the current CPU to use the deepest idle state with the exit
latency within @latency_limit"

>   */
> -void cpuidle_use_deepest_state(bool enable)
> +void cpuidle_use_latency(unsigned int latency)

I wouldn't change the name of the function (because why really?).

>  {
>         struct cpuidle_device *dev;
>
>         preempt_disable();
>         dev = cpuidle_get_device();
>         if (dev)
> -               dev->use_deepest_state = enable;
> +               dev->use_latency = latency;
>         preempt_enable();
>  }
>
> diff --git a/include/linux/cpuidle.h b/include/linux/cpuidle.h
> index d23a3b1ddcf6..32018704f4ea 100644
> --- a/include/linux/cpuidle.h
> +++ b/include/linux/cpuidle.h
> @@ -83,8 +83,8 @@ struct cpuidle_driver_kobj;
>  struct cpuidle_device {
>         unsigned int            registered:1;
>         unsigned int            enabled:1;
> -       unsigned int            use_deepest_state:1;
>         unsigned int            poll_time_limit:1;
> +       unsigned int            use_latency;

And maybe call this forced_idle_latency_limit or similar?

The idea being that when it is set, idle is forced (i.e. no
governors), but there is a latency limit for the state to use.

>         unsigned int            cpu;
>         ktime_t                 next_hrtimer;
>
> @@ -210,7 +210,7 @@ extern int cpuidle_find_deepest_state(struct cpuidle_driver *drv,
>                                       struct cpuidle_device *dev);
>  extern int cpuidle_enter_s2idle(struct cpuidle_driver *drv,
>                                 struct cpuidle_device *dev);
> -extern void cpuidle_use_deepest_state(bool enable);
> +extern void cpuidle_use_latency(unsigned int latency);
>  #else
>  static inline int cpuidle_find_deepest_state(struct cpuidle_driver *drv,
>                                              struct cpuidle_device *dev)
> @@ -218,7 +218,7 @@ static inline int cpuidle_find_deepest_state(struct cpuidle_driver *drv,
>  static inline int cpuidle_enter_s2idle(struct cpuidle_driver *drv,
>                                        struct cpuidle_device *dev)
>  {return -ENODEV; }
> -static inline void cpuidle_use_deepest_state(bool enable)
> +static inline void cpuidle_use_latency(unsigned int latency)
>  {
>  }
>  #endif
> diff --git a/kernel/sched/idle.c b/kernel/sched/idle.c
> index 8dad5aa600ea..00e064d3dfe1 100644
> --- a/kernel/sched/idle.c
> +++ b/kernel/sched/idle.c
> @@ -165,7 +165,7 @@ static void cpuidle_idle_call(void)
>          * until a proper wakeup interrupt happens.
>          */
>
> -       if (idle_should_enter_s2idle() || dev->use_deepest_state) {
> +       if (idle_should_enter_s2idle() || dev->use_latency) {
>                 if (idle_should_enter_s2idle()) {
>                         rcu_idle_enter();
>
> @@ -328,7 +328,7 @@ void play_idle(unsigned long duration_us)
>         rcu_sleep_check();
>         preempt_disable();
>         current->flags |= PF_IDLE;
> -       cpuidle_use_deepest_state(true);
> +       cpuidle_use_latency(1);
>
>         it.done = 0;
>         hrtimer_init_on_stack(&it.timer, CLOCK_MONOTONIC, HRTIMER_MODE_REL);
> @@ -339,7 +339,7 @@ void play_idle(unsigned long duration_us)
>         while (!READ_ONCE(it.done))
>                 do_idle();
>
> -       cpuidle_use_deepest_state(false);
> +       cpuidle_use_latency(0);
>         current->flags &= ~PF_IDLE;
>
>         preempt_fold_need_resched();
> --

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ